# CVE-2025-66204: WBCE CMS allows brute-force protection bypass using X-Forwarded-For header

> Attackers can bypass brute-force protection in WBCE CMS by spoofing the X-Forwarded-For header, enabling unlimited password guessing attempts.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-f676-f375-m7mw

## What is CVE-2025-66204?

CVE-2025-66204 is a medium-severity vulnerability in WBCE_CMS, published on 8 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WBCE CMS is a content management system. Version 1.6.4 contains a brute-force protection bypass where an attacker can indefinitely reset the counter by modifying `X-Forwarded-For` on each request, gaining unlimited password guessing attempts, effectively bypassing all brute-force protection. The application fully trusts the `X-Forwarded-For` header without validating it or restricting its usage. This issue is fixed in version 1.6.5.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-66204?

It affects 1 product.


Products: Wbce Wbce Cms.

## How do I fix CVE-2025-66204?

No fix has been published for CVE-2025-66204 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66204 exists.

Public exploit code:

- CVE-2025-66204 - WBCE CMS allows brute-force protection bypass using X-Forwarded-For header (github_poc): https://github.com/lukasz-rybak/CVE-2025-66204

## Other vulnerabilities in WBCE_CMS

- [CVE-2023-39796](https://insights.sbomify.com/CVE-2023-39796/): SQL injection in n/a (critical 9.8)
- [CVE-2022-46020](https://insights.sbomify.com/CVE-2022-46020/): File upload in n/a (critical 9.8)
- [CVE-2021-3817](https://insights.sbomify.com/CVE-2021-3817/): SQL Injection in wbce/wbce_cms (critical 9.8)
- [CVE-2025-65950](https://insights.sbomify.com/CVE-2025-65950/): WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter (critical 9.4)
- [CVE-2025-67504](https://insights.sbomify.com/CVE-2025-67504/): WBCE CMS has Weak Random Number Generator in Password Generation Function (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66204 and fix it if it is affected.

What it is: CVE-2025-66204 is a medium-severity vulnerability in WBCE_CMS, published on 8 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66204 exists.

Affected product: WBCE_CMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66204/ (Markdown: https://insights.sbomify.com/CVE-2025-66204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66204
- OSV: https://osv.dev/vulnerability/CVE-2025-66204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66204/
Summaries are generated and may contain mistakes; the official description above is the record.
