CVE-2025-66205 Frappe has the possibility of SQL Injection due to improper validations

High 7.1 Published Updated

Attackers can perform error-based SQL injection to retrieve sensitive information like version details from the Frappe web application framework.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-66205?

CVE-2025-66205 is a high-severity SQL injection vulnerability in frappe, published on 1 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.99.2.

Weakness: CWE-89

Which versions are affected by CVE-2025-66205?

It affects 1 product.

Products include Frappe Frappe.

How do I fix CVE-2025-66205?

No fix has been published for CVE-2025-66205 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-66205 being exploited?

There is no known exploitation of CVE-2025-66205 in the wild and no public exploit code.

Sources

Also known as GHSA-mp93-8vxr-hqq9.

Is CVE-2025-66205 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free