{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66214 exists.","fix":"No fix has been published for CVE-2025-66214 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-66214 is a high-severity unsafe deserialization vulnerability in wearefrank ladybug, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66214 and fix it if it is affected.\n\nWhat it is: CVE-2025-66214 is a high-severity unsafe deserialization vulnerability in wearefrank ladybug, published on 9 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66214 exists.\n\nAffected product: wearefrank ladybug. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66214/ (Markdown: https://insights.sbomify.com/CVE-2025-66214/index.md)","id":"CVE-2025-66214","markdown":"https://insights.sbomify.com/CVE-2025-66214/index.md","name":"CVE-2025-66214","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java testing library","requires_auth":"low_privilege","summary":"Attackers can achieve remote code execution by uploading crafted XML files to Ladybug's report APIs, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ladybug","vendor":"wearefrank"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Ladybug adds message-based debugging, unit, system, and regression testing to Java applications. Versions prior to 3.0-20251107.114628 contain the APIs /iaf/ladybug/api/report/{storage} and /iaf/ladybug/api/report/upload, which allow uploading gzip-compressed XML files with user-controllable content. The system deserializes these XML files, enabling attackers to achieve Remote Code Execution (RCE) by submitting carefully crafted XML payloads and thereby gain access to the target server. This issue is fixed in version 3.0-20251107.114628.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Ladybug has an XMLDecoder Deserialization Vulnerability (Java RCE)","id":"CVE-2025-66214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"OpenSC: Stack-buffer-overflow WRITE in card-oberthur","id":"CVE-2025-66215"},"packages":[],"prev":{"headline":"Coolify Vulnerable to Authenticated Remote Code Execution via Command Injection in File Storage Directory Mount Path","id":"CVE-2025-66213"},"products":["ladybug"],"published":"2025-12-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-09","vendors":["wearefrank"]},"summary":"Attackers can achieve remote code execution by uploading crafted XML files to Ladybug's report APIs, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2025-66214/"}