# CVE-2025-66216: AIS-catcher has a Buffer Overflow vulnerability in `AIS::Message` leading to DoS/RCE

> A heap buffer overflow in AIS-catcher allows attackers to execute arbitrary code or cause denial of service by writing data into a small buffer.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Nov 2025
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-v53x-f5hh-g2g6

## What is CVE-2025-66216?

CVE-2025-66216 is a critical memory corruption vulnerability in jvde-github AIS-catcher, published on 29 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, a heap buffer overflow vulnerability has been identified in the AIS::Message class of AIS-catcher. This vulnerability allows an attacker to write approximately 1KB of arbitrary data into a 128-byte buffer. This issue has been patched in version 0.64.

Weakness: CWE-787 (Out-of-bounds Write), CWE-131 (Incorrect Calculation of Buffer Size)

## Which versions are affected by CVE-2025-66216?

It affects 1 product.


Products: Aiscatcher Ais-Catcher.

## How do I fix CVE-2025-66216?

No fix has been published for CVE-2025-66216 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66216 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66216 exists.

## Other vulnerabilities in jvde-github AIS-catcher

- [CVE-2025-66217](https://insights.sbomify.com/CVE-2025-66217/): AIS-catcher Integer Underflow in MQTT Packet Parsing leading to Heap Buffer Overflow (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66216 and fix it if it is affected.

What it is: CVE-2025-66216 is a critical memory corruption vulnerability in jvde-github AIS-catcher, published on 29 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66216 exists.

Affected product: jvde-github AIS-catcher. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66216/ (Markdown: https://insights.sbomify.com/CVE-2025-66216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66216
- OSV: https://osv.dev/vulnerability/CVE-2025-66216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66216/
Summaries are generated and may contain mistakes; the official description above is the record.
