{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66217 exists.","fix":"No fix has been published for CVE-2025-66217 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-66217 is a high-severity vulnerability in jvde-github AIS-catcher, published on 29 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66217 and fix it if it is affected.\n\nWhat it is: CVE-2025-66217 is a high-severity vulnerability in jvde-github AIS-catcher, published on 29 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66217 exists.\n\nAffected product: jvde-github AIS-catcher. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66217/ (Markdown: https://insights.sbomify.com/CVE-2025-66217/index.md)","id":"CVE-2025-66217","markdown":"https://insights.sbomify.com/CVE-2025-66217/index.md","name":"CVE-2025-66217","record":{"aliases":["GHSA-93mj-c8q3-69rg"],"analysis":{"component_type":"iot_embedded","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"AIS receiver software","requires_auth":"none","summary":"Attackers can cause denial of service or remote code execution in AIS-catcher by sending malformed MQTT packets that trigger an integer underflow and heap buffer overflow.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ais-catcher","vendor":"aiscatcher"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, an integer underflow vulnerability exists in the MQTT parsing logic of AIS-catcher. This vulnerability allows an attacker to trigger a massive Heap Buffer Overflow by sending a malformed MQTT packet with a manipulated Topic Length field. This leads to an immediate Denial of Service (DoS) and, when used as a library, severe Memory Corruption that can be leveraged for Remote Code Execution (RCE). This issue has been patched in version 0.64.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"AIS-catcher Integer Underflow in MQTT Packet Parsing leading to Heap Buffer Overflow","id":"CVE-2025-66217","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"willitmerge has a command Injection vulnerability","id":"CVE-2025-66219"},"packages":[],"prev":{"headline":"AIS-catcher has a Buffer Overflow vulnerability in `AIS::Message` leading to DoS/RCE","id":"CVE-2025-66216"},"products":["AIS-catcher"],"published":"2025-11-29","related":[{"cvss_score":9.3,"headline":"AIS-catcher has a Buffer Overflow vulnerability in `AIS::Message` leading to DoS/RCE","id":"CVE-2025-66216","kev_date_added":null,"published":"2025-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-01","vendors":["jvde-github"]},"summary":"Attackers can cause denial of service or remote code execution in AIS-catcher by sending malformed MQTT packets that trigger an integer underflow and heap buffer overflow.","url":"https://insights.sbomify.com/CVE-2025-66217/"}