# CVE-2025-66217: AIS-catcher Integer Underflow in MQTT Packet Parsing leading to Heap Buffer Overflow

> Attackers can cause denial of service or remote code execution in AIS-catcher by sending malformed MQTT packets that trigger an integer underflow and heap buffer overflow.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Nov 2025
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-93mj-c8q3-69rg

## What is CVE-2025-66217?

CVE-2025-66217 is a high-severity vulnerability in jvde-github AIS-catcher, published on 29 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, an integer underflow vulnerability exists in the MQTT parsing logic of AIS-catcher. This vulnerability allows an attacker to trigger a massive Heap Buffer Overflow by sending a malformed MQTT packet with a manipulated Topic Length field. This leads to an immediate Denial of Service (DoS) and, when used as a library, severe Memory Corruption that can be leveraged for Remote Code Execution (RCE). This issue has been patched in version 0.64.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound)), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-66217?

It affects 1 product.


Products: Aiscatcher Ais-Catcher.

## How do I fix CVE-2025-66217?

No fix has been published for CVE-2025-66217 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66217 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66217 exists.

## Other vulnerabilities in jvde-github AIS-catcher

- [CVE-2025-66216](https://insights.sbomify.com/CVE-2025-66216/): AIS-catcher has a Buffer Overflow vulnerability in `AIS::Message` leading to DoS/RCE (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66217 and fix it if it is affected.

What it is: CVE-2025-66217 is a high-severity vulnerability in jvde-github AIS-catcher, published on 29 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66217 exists.

Affected product: jvde-github AIS-catcher. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66217/ (Markdown: https://insights.sbomify.com/CVE-2025-66217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66217
- OSV: https://osv.dev/vulnerability/CVE-2025-66217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66217/
Summaries are generated and may contain mistakes; the official description above is the record.
