# CVE-2025-66223: OpenObserve's Invite Token Lifecycle Misconfiguration

> Attackers can use non-expiring invitation tokens to regain access or escalate privileges in OpenObserve after user removal or role changes.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 Nov 2025
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-c856-2xpx-gw75

## What is CVE-2025-66223?

CVE-2025-66223 is a high-severity missing authorization vulnerability in openobserve, published on 29 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

OpenObserve is a cloud-native observability platform. Prior to version 0.16.0, organization invitation tokens do not expire once issued, remain valid even after the invited user is removed from the organization, and allow multiple invitations to the same email with different roles where all issued links remain valid simultaneously. This results in broken access control where a removed or demoted user can regain access or escalate privileges. This issue has been patched in version 0.16.0.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-66223?


## How do I fix CVE-2025-66223?

No fix has been published for CVE-2025-66223 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66223 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66223 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66223 and fix it if it is affected.

What it is: CVE-2025-66223 is a high-severity missing authorization vulnerability in openobserve, published on 29 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66223 exists.

Affected product: openobserve. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66223/ (Markdown: https://insights.sbomify.com/CVE-2025-66223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66223
- OSV: https://osv.dev/vulnerability/CVE-2025-66223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66223/
Summaries are generated and may contain mistakes; the official description above is the record.
