CVE-2025-66236 Apache Airflow: Secrets from Airflow config file logged in plain text in DAG run logs UI
Apache Airflow logs secrets from the configuration file in plain text within DAG run logs, exposing sensitive data to users with log access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66236?
CVE-2025-66236 is a high-severity vulnerability in Apache Airflow, published on 13 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Before Airflow 3.2.0, it was unclear that secure Airflow deployments require the Deployment Manager to take appropriate actions and pay attention to security details and security model of Airflow. Some assumptions the Deployment Manager could make were not clear or explicit enough, even though Airflow's intentions and security model of Airflow did not suggest different assumptions. The overall security model [1], workload isolation [2], and JWT authentication details [3] are now described in more detail. Users concerned with role isolation and following the Airflow security model of Airflow are advised to upgrade to Airflow 3.2, where several security improvements have been implemented. They should also read and follow the relevant documents to make sure that their deployment is secure enough. It also clarifies that the Deployment Manager is ultimately responsible for securing your Airflow deployment. This had also been communicated via Airflow 3.2.0 Blog announcement [4].
[1] Security Model: https://airflow.apache.org/docs/apache-airflow/stable/security/jwt_token_authentication.html [2] Workload isolation: https://airflow.apache.org/docs/apache-airflow/stable/security/workload.html [3] JWT Token authentication: https://airflow.apache.org/docs/apache-airflow/stable/security/jwt_token_authentication.html [4] Airflow 3.2.0 Blog announcement: https://airflow.apache.org/blog/airflow-3.2.0/
Users are recommended to upgrade to version 3.2.0, which fixes this issue.
Weakness: CWE-532
Which versions are affected by CVE-2025-66236?
4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-airflow PyPI | From 3.0.0 | 3.2.0 |
apache-airflow PyPI | From 3.0.0 | 3.2.0 |
apache-airflow PyPI | From 3.0.0 | 3.2.0 |
airflow Bitnami | From 3.0.0 | 3.2.0 |
Products include Apache Airflow.
How do I fix CVE-2025-66236?
Upgrade apache-airflow to 3.2.0 or later.
Is CVE-2025-66236 being exploited?
There is no known exploitation of CVE-2025-66236 in the wild and no public exploit code.
Other vulnerabilities in Apache Airflow
- CVE-2020-13927 Apache Airflow's Experimental API Authentication Bypass
- CVE-2020-11978 Apache Airflow Command Injection
- CVE-2026-33264 Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()
- CVE-2023-25754 Apache Airflow: Privilege escalation using airflow logs
- CVE-2023-22884 Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow
Sources
Also known as BIT-airflow-2025-66236, ECHO-16eb-cc5c-9b08, GHSA-j86x-fwp2-qh7v, MINI-7h6w-6mvc-p687, MINI-96f7-92gv-vjph, PYSEC-2026-8.