# CVE-2025-66249: Apache Livy: Unauthorized directory access

> Attackers can bypass directory restrictions to access unauthorized files if specific non-default settings are enabled in Apache Livy.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2026
- **Updated:** 13 Mar 2026
- **Also known as:** GHSA-h84f-4ff9-8hc3

## What is CVE-2025-66249?

CVE-2025-66249 is a medium-severity path traversal vulnerability in Apache Livy, published on 13 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Livy.

This issue affects Apache Livy: from 0.3.0 before 0.9.0.

The vulnerability can only be exploited with non-default Apache Livy Server settings. If the configuration value "livy.file.local-dir-whitelist" is set to a non-default value, the directory checking can be bypassed.

Users are recommended to upgrade to version 0.9.0, which fixes the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-66249?

2 open source packages ship an affected version, including org.apache.livy:livy-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.livy:livy-server` | Maven | From 0.3.0-incubating | 0.9.0-incubating |
| `org.apache.livy:livy-server` | Maven | From 0.3.0-incubating | 0.9.0-incubating |

Products: Apache Livy.

## How do I fix CVE-2025-66249?

Upgrade org.apache.livy:livy-server to 0.9.0-incubating or later.

## Is CVE-2025-66249 being exploited?

There is no known exploitation of CVE-2025-66249 in the wild and no public exploit code.

Public exploit code:

- A POC for Apache Livy Path Traversal Whitelist Bypass Vulnerability (github_poc): https://github.com/sid6224/CVE-2025-66249-POC

## Other vulnerabilities in Apache Livy

- [CVE-2025-60012](https://insights.sbomify.com/CVE-2025-60012/): Apache Livy: Restrict file access (medium 6.3)
- [CVE-2021-26544](https://insights.sbomify.com/CVE-2021-26544/): Apache Livy (Incubating) is vulnerable to cross site scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66249 and fix it if it is affected.

What it is: CVE-2025-66249 is a medium-severity path traversal vulnerability in Apache Livy, published on 13 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66249 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.livy:livy-server (Maven): affected from 0.3.0-incubating; fixed in 0.9.0-incubating
- org.apache.livy:livy-server (Maven): affected from 0.3.0-incubating; fixed in 0.9.0-incubating

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66249/ (Markdown: https://insights.sbomify.com/CVE-2025-66249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66249
- OSV: https://osv.dev/vulnerability/CVE-2025-66249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66249/
Summaries are generated and may contain mistakes; the official description above is the record.
