# CVE-2025-66294: Grav is vulnerable to RCE via SSTI through Twig Sandbox Bypass

> Authenticated attackers can execute arbitrary commands on the server via Server-Side Template Injection in Grav CMS.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-662m-56v4-3r8f

## What is CVE-2025-66294?

CVE-2025-66294 is a high-severity code injection vulnerability in Getgrav Grav, published on 1 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 1.8.0-beta.27, a Server-Side Template Injection (SSTI) vulnerability exists in Grav that allows authenticated attackers with editor permissions to execute arbitrary commands on the server and, under certain conditions, may also be exploited by unauthenticated attackers. This vulnerability stems from weak regex validation in the cleanDangerousTwig method. This vulnerability is fixed in 1.8.0-beta.27.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2025-66294?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.8.0-beta.27 |
| `getgrav/grav` | Packagist | All versions | 1.8.0-beta.27 |

Products: Getgrav Grav.

## How do I fix CVE-2025-66294?

Upgrade getgrav/grav to 1.8.0-beta.27 or later.

## Is CVE-2025-66294 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66294 exists.

Public exploit code:

- Grav CMS Twig SSTI Authenticated Sandbox Bypass RCE (metasploit)

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66294 and fix it if it is affected.

What it is: CVE-2025-66294 is a high-severity code injection vulnerability in Getgrav Grav, published on 1 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66294 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27
- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66294/ (Markdown: https://insights.sbomify.com/CVE-2025-66294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66294
- OSV: https://osv.dev/vulnerability/CVE-2025-66294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66294/
Summaries are generated and may contain mistakes; the official description above is the record.
