{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66298 exists.","fix":"Upgrade getgrav/grav to 1.8.0-beta.27 or later.","what":"CVE-2025-66298 is a high-severity code injection vulnerability in Getgrav Grav, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66298 and fix it if it is affected.\n\nWhat it is: CVE-2025-66298 is a high-severity code injection vulnerability in Getgrav Grav, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66298 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27\n- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66298/ (Markdown: https://insights.sbomify.com/CVE-2025-66298/index.md)","id":"CVE-2025-66298","markdown":"https://insights.sbomify.com/CVE-2025-66298/index.md","name":"CVE-2025-66298","record":{"aliases":["GHSA-8535-hvm8-2hmv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav web platform","requires_auth":"none","summary":"Attackers can exploit Server-Side Template Injection in Grav forms to read sensitive configuration data and potentially execute code.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"grav","vendor":"getgrav"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Grav is a file-based Web platform. Prior to 1.8.0-beta.27, having a simple form on site can reveal the whole Grav configuration details (including plugin configuration details) by using the correct POST payload to exploit a Server-Side Template (SST) vulnerability. Sensitive information may be contained in the configuration details. This vulnerability is fixed in 1.8.0-beta.27.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav is vulnerable to Server-Side Template Injection (SSTI) via Forms","id":"CVE-2025-66298","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"getgrav:grav","products":["getgrav:grav"],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Security Sandbox Bypass with SSTI (Server Side Template Injection) in the Grav CMS","id":"CVE-2025-66299"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.0-beta.27"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-8535-hvm8-2hmv"},{"ecosystem":"Packagist","fixed":["1.8.0-beta.27"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-8535-hvm8-2hmv"}],"prev":{"headline":"Grav vulnerable to Privilege Escalation and Authenticated Remote Code Execution via Twig Injection","id":"CVE-2025-66297"},"products":["grav"],"published":"2025-12-01","related":[{"cvss_score":10,"headline":"Grav Server Side Template Injection vulnerability","id":"CVE-2023-34251","kev_date_added":null,"published":"2023-06-14"},{"cvss_score":9.8,"headline":"Cross-site scripting in n/a","id":"CVE-2025-46199","kev_date_added":null,"published":"2025-07-25"},{"cvss_score":9.3,"headline":"GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2)","id":"CVE-2021-47812","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":9.1,"headline":"Grav may be vulnerable to SSRF attack via Twig Templates","id":"CVE-2025-66844","kev_date_added":null,"published":"2025-12-15"},{"cvss_score":9.1,"headline":"Code Injection in getgrav/grav","id":"CVE-2022-2073","kev_date_added":null,"published":"2022-06-29"},{"cvss_score":8.9,"headline":"Grav: Stored XSS via Tag Injection","id":"CVE-2026-42611","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":8.8,"headline":"Grav: Unauthenticated Path Traversal \u0026 Arbitrary File Write in FormFlash component.","id":"CVE-2026-42608","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-02","vendors":["getgrav"]},"summary":"Attackers can exploit Server-Side Template Injection in Grav forms to read sensitive configuration data and potentially execute code.","url":"https://insights.sbomify.com/CVE-2025-66298/"}