{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66301 exists.","fix":"Upgrade getgrav/grav to 1.8.0-beta.27 or later.","what":"CVE-2025-66301 is a high-severity missing authorization vulnerability in Getgrav Grav, published on 1 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66301 and fix it if it is affected.\n\nWhat it is: CVE-2025-66301 is a high-severity missing authorization vulnerability in Getgrav Grav, published on 1 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66301 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27\n- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66301/ (Markdown: https://insights.sbomify.com/CVE-2025-66301/index.md)","id":"CVE-2025-66301","markdown":"https://insights.sbomify.com/CVE-2025-66301/index.md","name":"CVE-2025-66301","record":{"aliases":["GHSA-v8x2-fjv7-8hjh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"An editor can bypass authorization checks to modify form processing actions, potentially leading to privilege escalation or code execution.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"grav","vendor":"getgrav"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Grav is a file-based Web platform. Prior to 1.8.0-beta.27, due to improper authorization checks when modifying critical fields on a POST request to /admin/pages/{page_name}, an editor with only permissions to change basic content on the form is now able to change the functioning of the form through modifying the content of the data[_json][header][form] which is the YAML frontmatter which includes the process section which dictates what happens after a user submits the form which include some important actions that could lead to further vulnerabilities. This vulnerability is fixed in 1.8.0-beta.27.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2025-12-01","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2025-12-01","kind":"metasploit","ref":"exploit/multi/http/grav_twig_ssti_sandbox_bypass_rce","stars":null,"title":"Grav CMS Twig SSTI Authenticated Sandbox Bypass RCE"}],"tier":"weaponised"},"has_fix":true,"headline":"Grav has Broken Access Control which allows an Editor to modify the page's YAML Frontmatter to alter form processing actions","id":"CVE-2025-66301","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"getgrav:grav","products":["getgrav:grav"],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Grav vulnerable to Path Traversal allowing server files backup","id":"CVE-2025-66302"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.0-beta.27"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-v8x2-fjv7-8hjh"},{"ecosystem":"Packagist","fixed":["1.8.0-beta.27"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-v8x2-fjv7-8hjh"}],"prev":{"headline":"Grav is vulnerable to Arbitrary File Read","id":"CVE-2025-66300"},"products":["grav"],"published":"2025-12-01","related":[{"cvss_score":10,"headline":"Grav Server Side Template Injection vulnerability","id":"CVE-2023-34251","kev_date_added":null,"published":"2023-06-14"},{"cvss_score":9.8,"headline":"Cross-site scripting in n/a","id":"CVE-2025-46199","kev_date_added":null,"published":"2025-07-25"},{"cvss_score":9.3,"headline":"GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2)","id":"CVE-2021-47812","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":9.1,"headline":"Grav may be vulnerable to SSRF attack via Twig Templates","id":"CVE-2025-66844","kev_date_added":null,"published":"2025-12-15"},{"cvss_score":9.1,"headline":"Code Injection in getgrav/grav","id":"CVE-2022-2073","kev_date_added":null,"published":"2022-06-29"},{"cvss_score":8.9,"headline":"Grav: Stored XSS via Tag Injection","id":"CVE-2026-42611","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":8.8,"headline":"Grav: Unauthenticated Path Traversal \u0026 Arbitrary File Write in FormFlash component.","id":"CVE-2026-42608","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-02","vendors":["getgrav"]},"summary":"An editor can bypass authorization checks to modify form processing actions, potentially leading to privilege escalation or code execution.","url":"https://insights.sbomify.com/CVE-2025-66301/"}