# CVE-2025-66304: Grav Exposes Password Hashes Leading to privilege escalation

> Attackers with admin panel read access can view password hashes, potentially leading to privilege escalation via offline cracking.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-gq3g-666w-7h85

## What is CVE-2025-66304?

CVE-2025-66304 is a medium-severity vulnerability in Getgrav Grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 1.8.0-beta.27, users with read access on the user account management section of the admin panel can view the password hashes of all users, including the admin user. This exposure can potentially lead to privilege escalation if an attacker can crack these password hashes. This vulnerability is fixed in 1.8.0-beta.27.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-66304?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.8.0-beta.27 |
| `getgrav/grav` | Packagist | All versions | 1.8.0-beta.27 |

Products: Getgrav Grav.

## How do I fix CVE-2025-66304?

Upgrade getgrav/grav to 1.8.0-beta.27 or later.

## Is CVE-2025-66304 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66304 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66304 and fix it if it is affected.

What it is: CVE-2025-66304 is a medium-severity vulnerability in Getgrav Grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66304 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27
- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66304/ (Markdown: https://insights.sbomify.com/CVE-2025-66304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66304
- OSV: https://osv.dev/vulnerability/CVE-2025-66304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66304/
Summaries are generated and may contain mistakes; the official description above is the record.
