# CVE-2025-66305: Grav vulnerable to Denial of Service via Improper Input Handling in 'Supported' Parameter

> An attacker can cause a complete site outage by submitting malformed input to the Supported parameter in the Grav admin panel.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-m8vh-v6r6-w7p6

## What is CVE-2025-66305?

CVE-2025-66305 is a medium-severity denial of service vulnerability in Getgrav Grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 1.8.0-beta.27, a Denial of Service (DoS) vulnerability was identified in the "Languages" submenu of the Grav admin configuration panel (/admin/config/system). Specifically, the Supported parameter fails to properly validate user input. If a malformed value is inserted—such as a single forward slash (/) or an XSS test string—it causes a fatal regular expression parsing error on the server. This leads to application-wide failure due to the use of the preg_match() function with an improperly constructed regular expression, resulting in an error. Once triggered, the site becomes completely unavailable to all users. This vulnerability is fixed in 1.8.0-beta.27.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-66305?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.8.0-beta.27 |
| `getgrav/grav` | Packagist | All versions | 1.8.0-beta.27 |

Products: Getgrav Grav.

## How do I fix CVE-2025-66305?

Upgrade getgrav/grav to 1.8.0-beta.27 or later.

## Is CVE-2025-66305 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66305 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66305 and fix it if it is affected.

What it is: CVE-2025-66305 is a medium-severity denial of service vulnerability in Getgrav Grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66305 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27
- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66305/ (Markdown: https://insights.sbomify.com/CVE-2025-66305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66305
- OSV: https://osv.dev/vulnerability/CVE-2025-66305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66305/
Summaries are generated and may contain mistakes; the official description above is the record.
