CVE-2025-66307 Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure

Medium 6.5 Published Updated

Attackers can enumerate valid usernames and disclose associated email addresses via the Forgot Password feature, enabling targeted phishing or password spraying attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-66307?

CVE-2025-66307 is a medium-severity vulnerability in getgrav grav, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a user enumeration and email disclosure vulnerability exists in Grav. The "Forgot Password" functionality at /admin/forgot leaks information about valid usernames and their associated email addresses through distinct server responses. This allows an attacker to enumerate users and disclose sensitive email addresses, which can be leveraged for targeted attacks such as password spraying, phishing, or social engineering. This vulnerability is fixed in 1.11.0-beta.1.

Weakness: CWE-204

Which versions are affected by CVE-2025-66307?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.

PackageAffectedFixed in
getgrav/grav PackagistAll versions1.8.0-beta.27
getgrav/grav PackagistAll versions1.8.0-beta.27

Products include Getgrav Grav-Plugin-Admin.

How do I fix CVE-2025-66307?

Upgrade getgrav/grav to 1.8.0-beta.27 or later.

Is CVE-2025-66307 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66307 exists.

Sources

Also known as GHSA-q3qx-cp62-f6m7.

Is CVE-2025-66307 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free