CVE-2025-66308 Grav Admin Plugin vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/config/site` parameter `data[taxonomies]`

Medium 6.8 Published Updated

Attackers can inject malicious scripts into site configuration taxonomies, leading to persistent XSS and potential account takeover for admin users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-66308?

CVE-2025-66308 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/config/site endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[taxonomies] parameter. The injected payload is stored on the server and automatically executed in the browser of any user who accesses the affected site configuration, resulting in a persistent attack vector. This vulnerability is fixed in 1.11.0-beta.1.

Weakness: CWE-79

Which versions are affected by CVE-2025-66308?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.

PackageAffectedFixed in
getgrav/grav PackagistAll versions1.8.0-beta.27
getgrav/grav PackagistAll versions1.8.0-beta.27

Products include Getgrav Grav-Plugin-Admin.

How do I fix CVE-2025-66308?

Upgrade getgrav/grav to 1.8.0-beta.27 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-66308 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66308 exists.

Sources

Also known as GHSA-gqxx-248x-g29f.

Is CVE-2025-66308 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free