# CVE-2025-66309: Grav is vulnerable to Cross-Site Scripting (XSS) Reflected endpoint /admin/pages/[page], parameter data[header][content][items], located in the "Blog Config" tab

> Attackers can inject malicious scripts via the Blog Config tab in Grav admin, potentially leading to code execution or account takeover.

- **Severity:** Medium 6.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-65mj-f7p4-wggq

## What is CVE-2025-66309?

CVE-2025-66309 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Reflected Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][content][items] parameter. This vulnerability is fixed in 1.11.0-beta.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-66309?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.8.0-beta.27 |
| `getgrav/grav` | Packagist | All versions | 1.8.0-beta.27 |

Products: Getgrav Grav-Plugin-Admin.

## How do I fix CVE-2025-66309?

Upgrade getgrav/grav to 1.8.0-beta.27 or later.

## Is CVE-2025-66309 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66309 exists.

## Other vulnerabilities in getgrav grav

- [CVE-2021-21425](https://insights.sbomify.com/CVE-2021-21425/): Unauthenticated Arbitrary YAML Write/Update leads to Code Execution (critical 9.3)
- [CVE-2025-66308](https://insights.sbomify.com/CVE-2025-66308/): Grav Admin Plugin vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/config/site` parameter `data[taxonomies]` (medium 6.8)
- [CVE-2025-66307](https://insights.sbomify.com/CVE-2025-66307/): Grav Admin Plugin vulnerable to User Enumeration & Email Disclosure (medium 6.5)
- [CVE-2025-66310](https://insights.sbomify.com/CVE-2025-66310/): Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` parameter `data[header][template]` in Advanced Tab (medium 6.2)
- [CVE-2025-66311](https://insights.sbomify.com/CVE-2025-66311/): Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters (medium 6.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66309 and fix it if it is affected.

What it is: CVE-2025-66309 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66309 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27
- getgrav/grav (Packagist): affected all versions; fixed in 1.8.0-beta.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66309/ (Markdown: https://insights.sbomify.com/CVE-2025-66309/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66309
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66309
- OSV: https://osv.dev/vulnerability/CVE-2025-66309

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66309/
Summaries are generated and may contain mistakes; the official description above is the record.
