{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66311 exists.","fix":"Upgrade getgrav/grav to 1.11.0-beta.1 or later.","what":"CVE-2025-66311 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-66311 and fix it if it is affected.\n\nWhat it is: CVE-2025-66311 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66311 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 1.11.0-beta.1\n- getgrav/grav (Packagist): affected all versions; fixed in 1.11.0-beta.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66311/ (Markdown: https://insights.sbomify.com/CVE-2025-66311/index.md)","id":"CVE-2025-66311","markdown":"https://insights.sbomify.com/CVE-2025-66311/index.md","name":"CVE-2025-66311","record":{"aliases":["GHSA-mpjj-4688-3fxg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts into Grav admin page parameters, leading to script execution in the administrative interface.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"grav-plugin-admin","vendor":"getgrav"}],"cvss":{"score":6.2,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][metadata], data[header][taxonomy][category], and data[header][taxonomy][tag] parameters. These scripts are stored in the page frontmatter and executed automatically whenever the affected page is accessed or rendered in the administrative interface. This vulnerability is fixed in 1.11.0-beta.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` in Multiples parameters","id":"CVE-2025-66311","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Grav Admin Plugin is vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/accounts/groups/[group]` parameter `data[readableName]`","id":"CVE-2025-66312"},"packages":[{"ecosystem":"Packagist","fixed":["1.11.0-beta.1"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-mpjj-4688-3fxg"},{"ecosystem":"Packagist","fixed":["1.11.0-beta.1"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-mpjj-4688-3fxg"}],"prev":{"headline":"Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` parameter `data[header][template]` in Advanced Tab","id":"CVE-2025-66310"},"products":["grav"],"published":"2025-12-01","related":[{"cvss_score":9.3,"headline":"Unauthenticated Arbitrary YAML Write/Update leads to Code Execution","id":"CVE-2021-21425","kev_date_added":null,"published":"2021-04-07"},{"cvss_score":6.8,"headline":"Grav Admin Plugin vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/config/site` parameter `data[taxonomies]`","id":"CVE-2025-66308","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.5,"headline":"Grav Admin Plugin vulnerable to User Enumeration \u0026 Email Disclosure","id":"CVE-2025-66307","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.2,"headline":"Grav is vulnerable to Cross-Site Scripting (XSS) Reflected endpoint /admin/pages/[page], parameter data[header][content][items], located in the \"Blog Config\" tab","id":"CVE-2025-66309","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.2,"headline":"Grav vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/pages/[page]` parameter `data[header][template]` in Advanced Tab","id":"CVE-2025-66310","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":6.2,"headline":"Grav Admin Plugin is vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/accounts/groups/[group]` parameter `data[readableName]`","id":"CVE-2025-66312","kev_date_added":null,"published":"2025-12-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-02","vendors":["getgrav"]},"summary":"Attackers can inject malicious scripts into Grav admin page parameters, leading to script execution in the administrative interface.","url":"https://insights.sbomify.com/CVE-2025-66311/"}