CVE-2025-66312 Grav Admin Plugin is vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/accounts/groups/[group]` parameter `data[readableName]`

Medium 6.2 Published Updated

Attackers can inject malicious scripts into the Grav Admin Plugin's group name field, leading to stored XSS and potential account takeover.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-66312?

CVE-2025-66312 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 1 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/accounts/groups/Grupo endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[readableName] parameter. The injected scripts are stored on the server and executed automatically whenever the affected page is accessed by users, posing a significant security risk. This vulnerability is fixed in 1.11.0-beta.1.

Weakness: CWE-79

Which versions are affected by CVE-2025-66312?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.

PackageAffectedFixed in
getgrav/grav PackagistAll versions1.8.0-beta.27
getgrav/grav PackagistAll versions1.8.0-beta.27

Products include Getgrav Grav-Plugin-Admin.

How do I fix CVE-2025-66312?

Upgrade getgrav/grav to 1.8.0-beta.27 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-66312 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66312 exists.

Sources

Also known as GHSA-rmw5-f87r-w988.

Is CVE-2025-66312 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free