# CVE-2025-66336: Apache Doris MCP Server: SQL injection leading the authentication bypass

> An attacker can exploit SQL injection in Apache Doris MCP Server to bypass authentication and access unauthorized metadata.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-pqrj-4gwg-h5f7, PYSEC-2026-4048

## What is CVE-2025-66336?

CVE-2025-66336 is a high-severity SQL injection vulnerability in Apache Doris MCP Server, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Doris MCP Server contains a SQL injection vulnerability in a metadata query path. A user-controlled database name is directly interpolated into a SQL query, and the query is executed without passing the caller's authorization context. This may allow an authenticated attacker, or an anonymous attacker if authentication is disabled, to bypass SQL security validation and access metadata outside the intended database scope.

Affected users are recommended to upgrade to Doris version 0.6.1 or later, which fixes the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-66336?

3 open source packages ship an affected version, including doris-mcp-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `doris-mcp-server` | PyPI | All versions | 0.6.1 |
| `doris-mcp-server` | PyPI | All versions | 0.6.1 |
| `doris-mcp-server` | PyPI | All versions | 0.6.1 |

Products: Apache Doris Mcp Server.

## How do I fix CVE-2025-66336?

Upgrade doris-mcp-server to 0.6.1 or later.

## Is CVE-2025-66336 being exploited?

There is no known exploitation of CVE-2025-66336 in the wild and no public exploit code.

## Other vulnerabilities in Apache Doris MCP Server

- [CVE-2025-58337](https://insights.sbomify.com/CVE-2025-58337/): Apache Doris-MCP-Server: Improper Access Control results in bypassing a "read-only" mode (medium 5.4)
- [CVE-2025-66335](https://insights.sbomify.com/CVE-2025-66335/): Apache Doris MCP Server: MCP SQL inject (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66336 and fix it if it is affected.

What it is: CVE-2025-66336 is a high-severity SQL injection vulnerability in Apache Doris MCP Server, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66336 in the wild and no public exploit code.

Affected packages and fixed versions:
- doris-mcp-server (PyPI): affected all versions; fixed in 0.6.1
- doris-mcp-server (PyPI): affected all versions; fixed in 0.6.1
- doris-mcp-server (PyPI): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66336/ (Markdown: https://insights.sbomify.com/CVE-2025-66336/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66336
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66336
- OSV: https://osv.dev/vulnerability/CVE-2025-66336

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66336/
Summaries are generated and may contain mistakes; the official description above is the record.
