# CVE-2025-66371: Peppol-py is vulnerable to XXE attacks due to Saxon configuration

> An attacker can exploit an XML External Entity vulnerability in Peppol-py to read local files and expose their content to a remote host.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2025
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-24hm-wm2h-h8w7, PYSEC-2026-1765

## What is CVE-2025-66371?

CVE-2025-66371 is a medium-severity vulnerability in Iteras Peppol-py, published on 28 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Peppol-py before 1.1.1 allows XXE attacks because of the Saxon configuration. When validating XML-based invoices, the XML parser could read files from the filesystem and expose their content to a remote host.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-66371?

3 open source packages ship an affected version, including peppol-py and peppol_py.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `peppol-py` | PyPI | All versions | 1.1.1 |
| `peppol-py` | PyPI | All versions | 1.1.1 |
| `peppol_py` | PyPI | All versions | 1.1.1 |

## How do I fix CVE-2025-66371?

Upgrade peppol-py to 1.1.1 or later.

## Is CVE-2025-66371 being exploited?

There is no known exploitation of CVE-2025-66371 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66371 and fix it if it is affected.

What it is: CVE-2025-66371 is a medium-severity vulnerability in Iteras Peppol-py, published on 28 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66371 in the wild and no public exploit code.

Affected packages and fixed versions:
- peppol-py (PyPI): affected all versions; fixed in 1.1.1
- peppol-py (PyPI): affected all versions; fixed in 1.1.1
- peppol_py (PyPI): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66371/ (Markdown: https://insights.sbomify.com/CVE-2025-66371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66371
- OSV: https://osv.dev/vulnerability/CVE-2025-66371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66371/
Summaries are generated and may contain mistakes; the official description above is the record.
