# CVE-2025-66398: Signal K Server has Unauthenticated State Pollution leading to Remote Code Execution (RCE)

> Unauthenticated attackers can pollute server state to overwrite configuration files, leading to remote code execution and account takeover in Signal K Server.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jan 2026
- **Updated:** 5 Jan 2026
- **Also known as:** GHSA-w3x5-7c4c-66p9

## What is CVE-2025-66398?

CVE-2025-66398 is a critical code injection vulnerability in signalk-server, published on 1 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Signal K Server is a server application that runs on a central hub in a boat. Prior to version 2.19.0, an unauthenticated attacker can pollute the internal state (`restoreFilePath`) of the server via the `/skServer/validateBackup` endpoint. This allows the attacker to hijack the administrator's "Restore" functionality to overwrite critical server configuration files (e.g., `security.json`, `package.json`), leading to account takeover and Remote Code Execution (RCE). Version 2.19.0 patches this vulnerability.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-66398?

2 open source packages ship an affected version, including signalk-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `signalk-server` | npm | All versions | 2.19.0 |
| `signalk-server` | npm | All versions | 2.19.0 |

Products: Signalk Signal K Server.

## How do I fix CVE-2025-66398?

Upgrade signalk-server to 2.19.0 or later.

## Is CVE-2025-66398 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66398 exists.

Public exploit code:

- CVE-2025-66398 — Signal K Server ≤ 2.18.0 RCE PoC  (github_poc): https://github.com/joshuavanderpoll/cve-2025-66398
- Demonstrate exploitation of Signal K Server CVE-2025-66398 allowing unauthenticated attackers to inject backdoor and enable remote code execution. (github_poc): https://github.com/showy-headteacher114/cve-2025-66398

## Other vulnerabilities in signalk-server

- [CVE-2026-23515](https://insights.sbomify.com/CVE-2026-23515/): RCE - Command Injection in Signal K set-system-time plugin (critical 10.0)
- [CVE-2026-33950](https://insights.sbomify.com/CVE-2026-33950/): signalk-server: Privilege Escalation by Admin Role Injection via /enableSecurity (critical 9.4)
- [CVE-2025-68620](https://insights.sbomify.com/CVE-2025-68620/): Signal K Server vulnerable to JWT Token Theft via WebSocket Enumeration and Unauthenticated Polling (critical 9.1)
- [CVE-2026-41893](https://insights.sbomify.com/CVE-2026-41893/): Signal K Server's WebSocket Login Endpoint Lacks Rate Limiting (Credential Brute-Force) (high 8.7)
- [CVE-2026-39320](https://insights.sbomify.com/CVE-2026-39320/): Signal K Server has an Unauthenticated Regular Expression Denial of Service (ReDoS) via WebSocket Subscription Paths (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66398 and fix it if it is affected.

What it is: CVE-2025-66398 is a critical code injection vulnerability in signalk-server, published on 1 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66398 exists.

Affected packages and fixed versions:
- signalk-server (npm): affected all versions; fixed in 2.19.0
- signalk-server (npm): affected all versions; fixed in 2.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66398/ (Markdown: https://insights.sbomify.com/CVE-2025-66398/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66398
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66398
- OSV: https://osv.dev/vulnerability/CVE-2025-66398

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66398/
Summaries are generated and may contain mistakes; the official description above is the record.
