# CVE-2025-66399: SNMP Command Injection leads to RCE in Cacti

> An authenticated user can inject commands via crafted SNMP community strings, leading to remote code execution on the Cacti server.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 8 Dec 2025
- **Also known as:** DEBIAN-CVE-2025-66399, GHSA-c7rr-2h93-7gjf, UBUNTU-CVE-2025-66399

## What is CVE-2025-66399?

CVE-2025-66399 is a high-severity command injection vulnerability in Cacti Cacti, published on 2 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cacti is an open source performance and fault management framework. Prior to 1.2.29, there is an input-validation flaw in the SNMP device configuration functionality. An authenticated Cacti user can supply crafted SNMP community strings containing control characters (including newlines) that are accepted, stored verbatim in the database, and later embedded into backend SNMP operations. In environments where downstream SNMP tooling or wrappers interpret newline-separated tokens as command boundaries, this can lead to unintended command execution with the privileges of the Cacti process. This vulnerability is fixed in 1.2.29.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-66399?

It affects 1 product.


Products: Cacti Cacti.

## How do I fix CVE-2025-66399?

Upgrade to a fixed version.

## Is CVE-2025-66399 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66399 exists.

## Other vulnerabilities in Cacti Cacti

- [CVE-2022-46169](https://insights.sbomify.com/CVE-2022-46169/): Cacti Command Injection (critical 9.8, exploited in the wild)
- [CVE-2026-39893](https://insights.sbomify.com/CVE-2026-39893/): Cacti: Pre-authentication SQL injection via rfilter RLIKE clause in graph_view.php (critical 9.8)
- [CVE-2026-39938](https://insights.sbomify.com/CVE-2026-39938/): Cacti: Unauthenticated RCE on Graph Image (critical 9.8)
- [CVE-2026-39955](https://insights.sbomify.com/CVE-2026-39955/): Cacti has Pre-Authentication SQL Injection via unanchored FILTER_VALIDATE_REGEXP in graph_view.php (critical 9.8)
- [CVE-2023-39361](https://insights.sbomify.com/CVE-2023-39361/): Unauthenticated SQL Injection in graph_view.php in Cacti (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66399 and fix it if it is affected.

What it is: CVE-2025-66399 is a high-severity command injection vulnerability in Cacti Cacti, published on 2 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66399 exists.

Affected product: Cacti Cacti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66399/ (Markdown: https://insights.sbomify.com/CVE-2025-66399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66399
- OSV: https://osv.dev/vulnerability/CVE-2025-66399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66399/
Summaries are generated and may contain mistakes; the official description above is the record.
