{"answers":{"affected":"2 open source packages ship an affected version, including mcp-server-kubernetes. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66404 exists.","fix":"Upgrade mcp-server-kubernetes to 2.9.8 or later.","what":"CVE-2025-66404 is a medium-severity command injection vulnerability in Flux159 mcp-server-kubernetes, published on 3 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-66404 and fix it if it is affected.\n\nWhat it is: CVE-2025-66404 is a medium-severity command injection vulnerability in Flux159 mcp-server-kubernetes, published on 3 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66404 exists.\n\nAffected packages and fixed versions:\n- mcp-server-kubernetes (npm): affected all versions; fixed in 2.9.8\n- mcp-server-kubernetes (npm): affected all versions; fixed in 2.9.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66404/ (Markdown: https://insights.sbomify.com/CVE-2025-66404/index.md)","id":"CVE-2025-66404","markdown":"https://insights.sbomify.com/CVE-2025-66404/index.md","name":"CVE-2025-66404","record":{"aliases":["GHSA-wvxp-jp4w-w8wg"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes MCP server","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary shell commands via the exec_in_pod tool due to lack of input validation, potentially compromising Kubernetes clusters.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mcp-server-kubernetes","vendor":"suyogs"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"MCP Server Kubernetes is an MCP Server that can connect to a Kubernetes cluster and manage it. Prior to 2.9.8, there is a security issue exists in the exec_in_pod tool of the mcp-server-kubernetes MCP Server. The tool accepts user-provided commands in both array and string formats. When a string format is provided, it is passed directly to shell interpretation (sh -c) without input validation, allowing shell metacharacters to be interpreted. This vulnerability can be exploited through direct command injection or indirect prompt injection attacks, where AI agents may execute commands without explicit user intent. This vulnerability is fixed in 2.9.8.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"mcp-server-kubernetes potential security issue in exec_in_pod tool","id":"CVE-2025-66404","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Portkey.ai Gateway: Server-Side Request Forgery (SSRF) in Custom Host","id":"CVE-2025-66405"},"packages":[{"ecosystem":"npm","fixed":["2.9.8"],"introduced":["0"],"last_affected":[],"package":"mcp-server-kubernetes","purl":null,"source":"GHSA-wvxp-jp4w-w8wg"},{"ecosystem":"npm","fixed":["2.9.8"],"introduced":["0"],"last_affected":[],"package":"mcp-server-kubernetes","purl":"pkg:npm/mcp-server-kubernetes","source":"GHSA-wvxp-jp4w-w8wg"}],"prev":{"headline":"FileRise Vulnerable to Stored XSS via SVG Upload","id":"CVE-2025-66403"},"products":["mcp-server-kubernetes"],"published":"2025-12-03","related":[{"cvss_score":9.3,"headline":"MCP Server Kubernetes \u003c 3.9.0 Argument Injection via kubectl Structured Tools","id":"CVE-2026-61459","kev_date_added":null,"published":"2026-07-10"},{"cvss_score":8.3,"headline":"MCP Server Kubernetes has Argument Injection in its port_forward tool via space-splitting","id":"CVE-2026-39884","kev_date_added":null,"published":"2026-04-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-03","vendors":["Flux159"]},"summary":"Attackers can execute arbitrary shell commands via the exec_in_pod tool due to lack of input validation, potentially compromising Kubernetes clusters.","url":"https://insights.sbomify.com/CVE-2025-66404/"}