# CVE-2025-66405: Portkey.ai Gateway: Server-Side Request Forgery (SSRF) in Custom Host

> Attackers can exploit a custom host header to force the AI Gateway to perform unauthorized external requests, potentially accessing internal resources.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-hhh5-2cvx-vmfp

## What is CVE-2025-66405?

CVE-2025-66405 is a medium-severity server-side request forgery vulnerability in Portkey-AI gateway, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Portkey.ai Gateway is a blazing fast AI Gateway with integrated guardrails. Prior to 1.14.0, the gateway determined the destination baseURL by prioritizing the value in the x-portkey-custom-host request header. The proxy route then appends the client-specified path to perform an external fetch. This can be maliciously used by users for SSRF attacks. This vulnerability is fixed in 1.14.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-66405?

2 open source packages ship an affected version, including @portkey-ai/gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@portkey-ai/gateway` | npm | All versions | 1.14.0 |
| `@portkey-ai/gateway` | npm | All versions | 1.14.0 |

Products: Portkey Gateway.

## How do I fix CVE-2025-66405?

Upgrade @portkey-ai/gateway to 1.14.0 or later.

## Is CVE-2025-66405 being exploited?

There is no known exploitation of CVE-2025-66405 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66405 and fix it if it is affected.

What it is: CVE-2025-66405 is a medium-severity server-side request forgery vulnerability in Portkey-AI gateway, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66405 in the wild and no public exploit code.

Affected packages and fixed versions:
- @portkey-ai/gateway (npm): affected all versions; fixed in 1.14.0
- @portkey-ai/gateway (npm): affected all versions; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66405/ (Markdown: https://insights.sbomify.com/CVE-2025-66405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66405
- OSV: https://osv.dev/vulnerability/CVE-2025-66405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66405/
Summaries are generated and may contain mistakes; the official description above is the record.
