# CVE-2025-66407: Weblate has Server-Side Request Forgery vulnerability

> Authorized users can exploit SSRF in Weblate's Mercurial component creation to access internal services and cloud metadata, potentially leading to credential disclosure.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2025
- **Updated:** 16 Dec 2025
- **Also known as:** GHSA-hfpv-mc5v-p9mm, PYSEC-2025-231

## What is CVE-2025-66407?

CVE-2025-66407 is a medium-severity server-side request forgery vulnerability in WeblateOrg weblate, published on 15 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weblate is a web based localization tool. The Create Component functionality in Weblate allows authorized users to add new translation components by specifying both a version control system and a source code repository URL to pull from. However, prior to version 5.15, the repository URL field is not validated or sanitized, allowing an attacker to supply arbitrary protocols, hostnames, and IP addresses, including localhost, internal network addresses, and local filenames. When the Mercurial version control system is selected, Weblate exposes the full server-side HTTP response for the provided URL. This effectively creates a server-side request forgery (SSRF) primitive that can probe internal services and return their contents. In addition to accessing internal HTTP endpoints, the behavior also enables local file enumeration by attempting file:// requests. While file contents may not always be returned, the application’s error messages clearly differentiate between files that exist and files that do not, revealing information about the server’s filesystem layout. In cloud environments, this behavior is particularly dangerous, as internal-only endpoints such as cloud metadata services may be accessible, potentially leading to credential disclosure and full environment compromise. This has been addressed in the Weblate 5.15 release. As a workaround, remove Mercurial from `VCS_BACKENDS`; the Git backend is not affected. The Git backend was already configured to block the file protocol and does not expose the HTTP response content in the error message.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-66407?

3 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.15 |
| `weblate` | PyPI | All versions | 5.15 |
| `Weblate` | PyPI | All versions | 5.15 |

Products: Weblate Weblate.

## How do I fix CVE-2025-66407?

Upgrade weblate to 5.15 or later.

## Is CVE-2025-66407 being exploited?

There is no known exploitation of CVE-2025-66407 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66407 and fix it if it is affected.

What it is: CVE-2025-66407 is a medium-severity server-side request forgery vulnerability in WeblateOrg weblate, published on 15 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66407 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.15
- weblate (PyPI): affected all versions; fixed in 5.15
- Weblate (PyPI): affected all versions; fixed in 5.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66407/ (Markdown: https://insights.sbomify.com/CVE-2025-66407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66407
- OSV: https://osv.dev/vulnerability/CVE-2025-66407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66407/
Summaries are generated and may contain mistakes; the official description above is the record.
