# CVE-2025-66410: Gin-vue-admin has an arbitrary file deletion vulnerability

> Attackers can delete arbitrary files and folders on the server by manipulating the FileMd5 parameter, leading to resource damage or unavailability.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-jrhg-82w2-vvj7, GO-2025-4171

## What is CVE-2025-66410?

CVE-2025-66410 is a high-severity path traversal vulnerability in flipped-aurora gin-vue-admin, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gin-vue-admin is a backstage management system based on vue and gin. In 2.8.6 and earlier, attackers can delete any file on the server at will, causing damage or unavailability of server resources. Attackers can control the 'FileMd5' parameter to delete any file and folder.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-66410?

3 open source packages ship an affected version, including github.com/flipped-aurora/gin-vue-admin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/flipped-aurora/gin-vue-admin` | Go | All versions | 0.9.1-0.20251201084432-ee8d8d7e04d9 |
| `github.com/flipped-aurora/gin-vue-admin` | Go | All versions | 0.9.1-0.20251201084432-ee8d8d7e04d9 |
| `github.com/flipped-aurora/gin-vue-admin` | Go | All versions | 0.9.1-0.20251201084432-ee8d8d7e04d9 |

Products: Gin-Vue-Admin Project Gin-Vue-Admin.

## How do I fix CVE-2025-66410?

Upgrade github.com/flipped-aurora/gin-vue-admin to 0.9.1-0.20251201084432-ee8d8d7e04d9 or later.

## Is CVE-2025-66410 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66410 exists.

## Other vulnerabilities in flipped-aurora gin-vue-admin

- [CVE-2022-39345](https://insights.sbomify.com/CVE-2022-39345/): Gin-vue-admin arbitrary file upload vulnerability caused by path traversal (critical 9.8)
- [CVE-2022-39305](https://insights.sbomify.com/CVE-2022-39305/): Gin-vue-admin vulnerable to Unrestricted Upload of File with Dangerous Type (critical 9.8)
- [CVE-2021-44219](https://insights.sbomify.com/CVE-2021-44219/): SQL injection in n/a (critical 9.8)
- [CVE-2022-32176](https://insights.sbomify.com/CVE-2022-32176/): Gin-vue-admin - Unrestricted File Upload (critical 9.0)
- [CVE-2022-32177](https://insights.sbomify.com/CVE-2022-32177/): Gin-vue-admin - Unrestricted File Upload (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66410 and fix it if it is affected.

What it is: CVE-2025-66410 is a high-severity path traversal vulnerability in flipped-aurora gin-vue-admin, published on 1 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66410 exists.

Affected packages and fixed versions:
- github.com/flipped-aurora/gin-vue-admin (Go): affected all versions; fixed in 0.9.1-0.20251201084432-ee8d8d7e04d9
- github.com/flipped-aurora/gin-vue-admin (Go): affected all versions; fixed in 0.9.1-0.20251201084432-ee8d8d7e04d9
- github.com/flipped-aurora/gin-vue-admin (Go): affected all versions; fixed in 0.9.1-0.20251201084432-ee8d8d7e04d9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66410/ (Markdown: https://insights.sbomify.com/CVE-2025-66410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66410
- OSV: https://osv.dev/vulnerability/CVE-2025-66410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66410/
Summaries are generated and may contain mistakes; the official description above is the record.
