# CVE-2025-66411: Coder logged sensitive objects unsanitized

> Attackers with local or log access can read sensitive workspace agent manifests due to unsanitized logging in Coder.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2025
- **Updated:** 3 Dec 2025
- **Also known as:** GHSA-jf75-p25m-pw74, GO-2025-4182

## What is CVE-2025-66411?

CVE-2025-66411 is a high-severity vulnerability in coder, published on 3 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Coder allows organizations to provision remote development environments via Terraform. Prior to 2.26.5, 2.27.7, and 2.28.4, Workspace Agent manifests containing sensitive values were logged in plaintext unsanitized. An attacker with limited local access to the Coder Workspace (VM, K8s Pod etc.) or a third-party system (SIEM, logging stack) could access those logs. This vulnerability is fixed in 2.26.5, 2.27.7, and 2.28.4.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-66411?

8 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coder/coder/v2` | Go | All versions | 2.26.5, 2.27.7, 2.28.4 |
| `github.com/coder/coder/v2` | Go | All versions | 2.26.5 |
| `github.com/coder/coder/v2` | Go | All versions | 2.26.5 |
| `github.com/coder/coder/v2` | Go | From 2.27.0 | 2.27.7 |
| `github.com/coder/coder/v2` | Go | From 2.27.0 | 2.27.7 |
| `github.com/coder/coder/v2` | Go | From 2.28.0 | 2.28.4 |
| `github.com/coder/coder/v2` | Go | From 2.28.0 | 2.28.4 |
| `github.com/coder/coder` | Go | All versions | None |

Products: Coder Coder.

## How do I fix CVE-2025-66411?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.26.5, 2.27.7 or 2.28.4.

## Is CVE-2025-66411 being exploited?

There is no known exploitation of CVE-2025-66411 in the wild and no public exploit code.

## Other vulnerabilities in coder

- [CVE-2026-46354](https://insights.sbomify.com/CVE-2026-46354/): Coder: PKCS#7 signature bypass in Azure instance identity allows unauthenticated agent token theft (critical 9.1)
- [CVE-2026-55429](https://insights.sbomify.com/CVE-2026-55429/): Coder's workspace app upsert allows cross-workspace agent rebinding via user-controlled app ID (high 8.7)
- [CVE-2026-55427](https://insights.sbomify.com/CVE-2026-55427/): Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh` (high 8.3)
- [CVE-2026-55428](https://insights.sbomify.com/CVE-2026-55428/): Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator (high 8.2)
- [CVE-2024-27918](https://insights.sbomify.com/CVE-2024-27918/): Coder's OIDC authentication allows email with partially matching domain to register (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66411 and fix it if it is affected.

What it is: CVE-2025-66411 is a high-severity vulnerability in coder, published on 3 Dec 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66411 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.26.5, 2.27.7, 2.28.4
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.26.5
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.26.5
- github.com/coder/coder/v2 (Go): affected from 2.27.0; fixed in 2.27.7
- github.com/coder/coder/v2 (Go): affected from 2.27.0; fixed in 2.27.7
- github.com/coder/coder/v2 (Go): affected from 2.28.0; fixed in 2.28.4
- github.com/coder/coder/v2 (Go): affected from 2.28.0; fixed in 2.28.4
- github.com/coder/coder (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66411/ (Markdown: https://insights.sbomify.com/CVE-2025-66411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66411
- OSV: https://osv.dev/vulnerability/CVE-2025-66411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66411/
Summaries are generated and may contain mistakes; the official description above is the record.
