# CVE-2025-66414: DNS Rebinding Protection Disabled by Default in Model Context Protocol TypeScript SDK for Servers Running on Localhost

> Attackers can use DNS rebinding to bypass same-origin policy and interact with local MCP servers if protection is disabled and authentication is missing.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** CLSA-2026-1789632492, CLSA-2026-1790202402, CVE-2025-11249, GHSA-w48q-cv73-mx4w, MINI-j4rv-88g7-gcc5, MINI-jgq7-2mjx-hf2c, MINI-w5qf-g4v5-v7fh, MINI-xmrj-75c9-p6f5, ROOT-APP-NPM-CVE-2025-66414

## What is CVE-2025-66414?

CVE-2025-66414 is a high-severity server-side request forgery vulnerability in modelcontextprotocol typescript-sdk, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

MCP TypeScript SDK is the official TypeScript SDK for Model Context Protocol servers and clients. Prior to 1.24.0, The Model Context Protocol (MCP) TypeScript SDK does not enable DNS rebinding protection by default for HTTP-based servers. When an HTTP-based MCP server is run on localhost without authentication with StreamableHTTPServerTransport or SSEServerTransport and has not enabled enableDnsRebindingProtection, a malicious website could exploit DNS rebinding to bypass same-origin policy restrictions and send requests to the local MCP server. This could allow an attacker to invoke tools or access resources exposed by the MCP server on behalf of the user in those limited circumstances. Note that running HTTP-based MCP servers locally without authentication is not recommended per MCP security best practices. This issue does not affect servers using stdio transport. This vulnerability is fixed in 1.24.0.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2025-66414?

2 open source packages ship an affected version, including @modelcontextprotocol/sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@modelcontextprotocol/sdk` | npm | All versions | 1.24.0 |
| `@modelcontextprotocol/sdk` | npm | All versions | 1.24.0 |

Products: Lfprojects Mcp Typescript Sdk.

## How do I fix CVE-2025-66414?

Upgrade @modelcontextprotocol/sdk to 1.24.0 or later.

## Is CVE-2025-66414 being exploited?

There is no known exploitation of CVE-2025-66414 in the wild and no public exploit code.

## Other vulnerabilities in modelcontextprotocol typescript-sdk

- [CVE-2026-0621](https://insights.sbomify.com/CVE-2026-0621/): MCP TypeScript SDK UriTemplate Exploded Array Pattern ReDoS (high 8.7)
- [CVE-2026-25536](https://insights.sbomify.com/CVE-2026-25536/): @modelcontextprotocol/sdk has cross-client data leak via shared server/transport instance reuse (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66414 and fix it if it is affected.

What it is: CVE-2025-66414 is a high-severity server-side request forgery vulnerability in modelcontextprotocol typescript-sdk, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-66414 in the wild and no public exploit code.

Affected packages and fixed versions:
- @modelcontextprotocol/sdk (npm): affected all versions; fixed in 1.24.0
- @modelcontextprotocol/sdk (npm): affected all versions; fixed in 1.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66414/ (Markdown: https://insights.sbomify.com/CVE-2025-66414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66414
- OSV: https://osv.dev/vulnerability/CVE-2025-66414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66414/
Summaries are generated and may contain mistakes; the official description above is the record.
