CVE-2025-66417 GLPI has an unauthenticated SQL injection through the inventory endpoint

High 7.5 Published Updated

Unauthenticated attackers can execute SQL injection via the inventory endpoint in GLPI, allowing unauthorized data access or modification.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-66417?

CVE-2025-66417 is a high-severity SQL injection vulnerability in Glpi-Project Glpi, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GLPI is a free asset and IT management software package. From 11.0.0, < 11.0.3, an unauthenticated user can perform a SQL injection through the inventory endpoint. This vulnerability is fixed in 11.0.3.

Weakness: CWE-89

Which versions are affected by CVE-2025-66417?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2025-66417?

No fix has been published for CVE-2025-66417 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-66417 being exploited?

There is no known exploitation of CVE-2025-66417 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-p467-682w-9cc9, UBUNTU-CVE-2025-66417.

Is CVE-2025-66417 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free