# CVE-2025-66419: MaxKB vulnerable to privilege escalation through sandbox bypass

> Attackers can escape the sandbox and escalate privileges in MaxKB via a race condition in the tool module.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** GHSA-f9qm-2pxq-fx6c

## What is CVE-2025-66419?

CVE-2025-66419 is a high-severity vulnerability in 1Panel-dev MaxKB, published on 11 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MaxKB is an open-source AI assistant for enterprise. In versions 2.3.1 and below, the tool module allows an attacker to escape the sandbox environment and escalate privileges under certain concurrent conditions. This issue is fixed in version 2.4.0.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2025-66419?

It affects 1 product.


Products: Maxkb Maxkb.

## How do I fix CVE-2025-66419?

No fix has been published for CVE-2025-66419 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66419 being exploited?

There is no known exploitation of CVE-2025-66419 in the wild and no public exploit code.

## Other vulnerabilities in 1Panel-dev MaxKB

- [CVE-2025-66446](https://insights.sbomify.com/CVE-2025-66446/): MaxKB has a Python sandbox LD_PRELOAD bypass (high 8.8)
- [CVE-2025-64511](https://insights.sbomify.com/CVE-2025-64511/): MaxKB has SSRF in sandbox (high 7.4)
- [CVE-2026-39422](https://insights.sbomify.com/CVE-2026-39422/): MaxKB has Stored XSS via ChatHeadersMiddleware (medium 6.9)
- [CVE-2026-39423](https://insights.sbomify.com/CVE-2026-39423/): Stored XSS via Eval Injection in EchartsRander Component (medium 6.9)
- [CVE-2024-56137](https://insights.sbomify.com/CVE-2024-56137/): MaxKB RCE vulnerability in function library (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66419 and fix it if it is affected.

What it is: CVE-2025-66419 is a high-severity vulnerability in 1Panel-dev MaxKB, published on 11 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66419 in the wild and no public exploit code.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66419/ (Markdown: https://insights.sbomify.com/CVE-2025-66419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66419
- OSV: https://osv.dev/vulnerability/CVE-2025-66419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66419/
Summaries are generated and may contain mistakes; the official description above is the record.
