# CVE-2025-66433: Auth bypass in HTCondor

> Authenticated users can impersonate others on the local machine by submitting batch jobs, leading to privilege escalation.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Nov 2025
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-7cjv-vw69-7fxx

## What is CVE-2025-66433?

CVE-2025-66433 is a medium-severity authentication bypass vulnerability in wisc HTCondor, published on 30 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

HTCondor Access Point before 25.3.1 allows an authenticated user to impersonate other users on the local machine by submitting a batch job. This is fixed in 24.12.14, 25.0.3, and 25.3.1. The earliest affected version is 24.7.3.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-66433?


## How do I fix CVE-2025-66433?

No fix has been published for CVE-2025-66433 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66433 being exploited?

There is no known exploitation of CVE-2025-66433 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66433 and fix it if it is affected.

What it is: CVE-2025-66433 is a medium-severity authentication bypass vulnerability in wisc HTCondor, published on 30 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66433 in the wild and no public exploit code.

Affected product: wisc HTCondor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66433/ (Markdown: https://insights.sbomify.com/CVE-2025-66433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66433
- OSV: https://osv.dev/vulnerability/CVE-2025-66433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66433/
Summaries are generated and may contain mistakes; the official description above is the record.
