# CVE-2025-66448: vLLM vulnerable to remote code execution via transformers_utils/get_config

> Attackers can achieve remote code execution by publishing malicious model configs that bypass trust_remote_code settings in vLLM.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-8fr4-5q9j-m8gm, PYSEC-2026-2015

## What is CVE-2025-66448?

CVE-2025-66448 is a high-severity code injection vulnerability in Vllm Vllm, published on 1 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.11.1, vllm has a critical remote code execution vector in a config class named Nemotron_Nano_VL_Config. When vllm loads a model config that contains an auto_map entry, the config class resolves that mapping with get_class_from_dynamic_module(...) and immediately instantiates the returned class. This fetches and executes Python from the remote repository referenced in the auto_map string. Crucially, this happens even when the caller explicitly sets trust_remote_code=False in vllm.transformers_utils.config.get_config. In practice, an attacker can publish a benign-looking frontend repo whose config.json points via auto_map to a separate malicious backend repo; loading the frontend will silently run the backend’s code on the victim host. This vulnerability is fixed in 0.11.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-66448?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.11.1 |
| `vllm` | PyPI | All versions | 0.11.1 |
| `vllm` | PyPI | All versions | 0.11.1 |

Products: Vllm Vllm.

## How do I fix CVE-2025-66448?

Upgrade vllm to 0.11.1 or later.

## Is CVE-2025-66448 being exploited?

There is no known exploitation of CVE-2025-66448 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66448 and fix it if it is affected.

What it is: CVE-2025-66448 is a high-severity code injection vulnerability in Vllm Vllm, published on 1 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-66448 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.11.1
- vllm (PyPI): affected all versions; fixed in 0.11.1
- vllm (PyPI): affected all versions; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66448/ (Markdown: https://insights.sbomify.com/CVE-2025-66448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66448
- OSV: https://osv.dev/vulnerability/CVE-2025-66448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66448/
Summaries are generated and may contain mistakes; the official description above is the record.
