CVE-2025-66450 LibreChat JSON Injection in Chat POST Allows Remote Resource Inclusion and PXSS via Image Upload

High 8.6 Published Updated

Attackers can inject malicious code via image URLs in chat posts, leading to privacy loss and potential script execution when chats are shared.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-66450?

CVE-2025-66450 is a high-severity cross-site scripting vulnerability in Librechat Librechat, published on 11 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when a user posts a question, the iconURL parameter of the POST request can be modified by an attacker. The malicious code is then stored in the chat which can then be shared to other users. When sharing chats with a potentially malicious “tracker”, resources loaded can lead to loss of privacy for users who view the chat link that is sent to them. This issue is fixed in version 0.8.1.

Weakness: CWE-80

Which versions are affected by CVE-2025-66450?

It affects 1 product.

Products include Librechat Librechat.

How do I fix CVE-2025-66450?

No fix has been published for CVE-2025-66450 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-66450 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66450 exists.

All Librechat Librechat vulnerabilities

Sources

Also known as GHSA-84vx-vmcf-xgpp.

Is CVE-2025-66450 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free