{"answers":{"affected":"3 open source packages ship an affected version, including arcade-mcp-server.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66454 exists.","fix":"Upgrade arcade-mcp-server to 1.9.1 or later.","what":"CVE-2025-66454 is a medium-severity vulnerability in ArcadeAI arcade-mcp, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66454 and fix it if it is affected.\n\nWhat it is: CVE-2025-66454 is a medium-severity vulnerability in ArcadeAI arcade-mcp, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66454 exists.\n\nAffected packages and fixed versions:\n- arcade-mcp-server (PyPI): affected all versions; fixed in 1.9.1\n- arcade-mcp-server (PyPI): affected all versions; fixed in 1.9.1\n- arcade-mcp-server (PyPI): affected all versions; fixed in 1.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66454/ (Markdown: https://insights.sbomify.com/CVE-2025-66454/index.md)","id":"CVE-2025-66454","markdown":"https://insights.sbomify.com/CVE-2025-66454/index.md","name":"CVE-2025-66454","record":{"aliases":["GHSA-g2jx-37x6-6438","PYSEC-2026-1192"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Arcade MCP server","requires_auth":"none","summary":"Attackers can use a hardcoded default secret to forge JWTs and gain unauthorized access to all Arcade MCP worker endpoints, enabling tool invocation.","user_interaction":"not_required","vuln_class":"hardcoded_credentials"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-798","name":"Use of Hard-coded Credentials"},{"id":"CWE-321","name":"Use of Hard-coded Cryptographic Key"}],"description":"Arcade MCP allows you to to create, deploy, and share MCP Servers. Prior to 1.5.4, the arcade-mcp HTTP server uses a hardcoded default worker secret (\"dev\") that is never validated or overridden during normal server startup. As a result, any unauthenticated attacker who knows this default key can forge valid JWTs and fully bypass the FastAPI authentication layer. This grants remote access to all worker endpoints—including tool enumeration and tool invocation—without credentials. This vulnerability is fixed in 1.5.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Arcade MCP Default Hardcoded Worker Secret Allows Full Unauthorized Access to All HTTP MCP Worker Endpoints","id":"CVE-2025-66454","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"hardcoded_credentials","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"LMDeploy has Remote Code Execution by Pickle Deserialization via handle_zmq_recv in lmdeploy/lmdeploy/pytorch/disagg/conn/engine_conn.py","id":"CVE-2025-66455"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"arcade-mcp-server","purl":null,"source":"GHSA-g2jx-37x6-6438"},{"ecosystem":"PyPI","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"arcade-mcp-server","purl":"pkg:pypi/arcade-mcp-server","source":"GHSA-g2jx-37x6-6438"},{"ecosystem":"PyPI","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"arcade-mcp-server","purl":"pkg:pypi/arcade-mcp-server","source":"PYSEC-2026-1192"}],"prev":{"headline":"Rhino vulnerable high CPU usage and potential DoS when passing specific numbers to toFixed() function","id":"CVE-2025-66453"},"products":["arcade-mcp"],"published":"2025-12-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-02","vendors":["ArcadeAI"]},"summary":"Attackers can use a hardcoded default secret to forge JWTs and gain unauthorized access to all Arcade MCP worker endpoints, enabling tool invocation.","url":"https://insights.sbomify.com/CVE-2025-66454/"}