# CVE-2025-66454: Arcade MCP Default Hardcoded Worker Secret Allows Full Unauthorized Access to All HTTP MCP Worker Endpoints

> Attackers can use a hardcoded default secret to forge JWTs and gain unauthorized access to all Arcade MCP worker endpoints, enabling tool invocation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-g2jx-37x6-6438, PYSEC-2026-1192

## What is CVE-2025-66454?

CVE-2025-66454 is a medium-severity vulnerability in ArcadeAI arcade-mcp, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Arcade MCP allows you to to create, deploy, and share MCP Servers. Prior to 1.5.4, the arcade-mcp HTTP server uses a hardcoded default worker secret ("dev") that is never validated or overridden during normal server startup. As a result, any unauthenticated attacker who knows this default key can forge valid JWTs and fully bypass the FastAPI authentication layer. This grants remote access to all worker endpoints—including tool enumeration and tool invocation—without credentials. This vulnerability is fixed in 1.5.4.

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-321 (Use of Hard-coded Cryptographic Key)

## Which versions are affected by CVE-2025-66454?

3 open source packages ship an affected version, including arcade-mcp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `arcade-mcp-server` | PyPI | All versions | 1.9.1 |
| `arcade-mcp-server` | PyPI | All versions | 1.9.1 |
| `arcade-mcp-server` | PyPI | All versions | 1.9.1 |

## How do I fix CVE-2025-66454?

Upgrade arcade-mcp-server to 1.9.1 or later.

## Is CVE-2025-66454 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66454 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66454 and fix it if it is affected.

What it is: CVE-2025-66454 is a medium-severity vulnerability in ArcadeAI arcade-mcp, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66454 exists.

Affected packages and fixed versions:
- arcade-mcp-server (PyPI): affected all versions; fixed in 1.9.1
- arcade-mcp-server (PyPI): affected all versions; fixed in 1.9.1
- arcade-mcp-server (PyPI): affected all versions; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66454/ (Markdown: https://insights.sbomify.com/CVE-2025-66454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66454
- OSV: https://osv.dev/vulnerability/CVE-2025-66454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66454/
Summaries are generated and may contain mistakes; the official description above is the record.
