# CVE-2025-66455: LMDeploy has Remote Code Execution by Pickle Deserialization via handle_zmq_recv in lmdeploy/lmdeploy/pytorch/disagg/conn/engine_conn.py

> Unauthenticated attackers can achieve remote code execution on LMDeploy DistServe servers by sending malicious pickle payloads via ZeroMQ.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-2vh9-42vm-xmv2, PYSEC-2026-4077

## What is CVE-2025-66455?

CVE-2025-66455 is a critical unsafe deserialization vulnerability in InternLM lmdeploy, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LMDeploy is a toolkit for compressing, deploying, and serving large language models. Starting in version 0.9.2 and prior to version 0.16.0, LMDeploy's PyTorch DistServe/PD-disaggregation control plane used `recv_pyobj()` to deserialize messages received through a ZeroMQ PULL socket. PyZMQ implements `recv_pyobj()` using Python pickle deserialization, which can execute arbitrary code while reconstructing an object. The peer address used by the receiver was supplied through the `POST /distserve/p2p_connect` HTTP endpoint. An attacker who could reach an affected DistServe API server could cause the server to connect to an attacker-controlled ZeroMQ endpoint and deserialize a crafted pickle payload. API-key authentication is not enabled unless the operator explicitly configures it. As a result, affected DistServe deployments without API keys allowed unauthenticated remote code execution with the privileges of the LMDeploy serving process. This issue affects the PyTorch backend when PD-disaggregation/DistServe is enabled. Ordinary deployments that do not use the affected disaggregated-serving path do not expose this data flow. The fix was released in LMDeploy 0.16.0. Users who cannot upgrade immediately should prevent untrusted clients from reaching `/distserve/*` endpoints, restrict the DistServe HTTP and ZeroMQ control planes to trusted cluster networks, configure API-key authentication, and block arbitrary outbound ZeroMQ connections from serving nodes. These measures reduce exposure but do not make pickle deserialization safe.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-66455?

3 open source packages ship an affected version, including lmdeploy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lmdeploy` | PyPI | From 0.9.2 | 0.16.0 |
| `lmdeploy` | PyPI | From 0.9.2 | 0.16.0 |
| `lmdeploy` | PyPI | From 0.9.2 | 0.16.0 |

## How do I fix CVE-2025-66455?

Upgrade lmdeploy to 0.16.0 or later.

## Is CVE-2025-66455 being exploited?

There is no known exploitation of CVE-2025-66455 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66455 and fix it if it is affected.

What it is: CVE-2025-66455 is a critical unsafe deserialization vulnerability in InternLM lmdeploy, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-66455 in the wild and no public exploit code.

Affected packages and fixed versions:
- lmdeploy (PyPI): affected from 0.9.2; fixed in 0.16.0
- lmdeploy (PyPI): affected from 0.9.2; fixed in 0.16.0
- lmdeploy (PyPI): affected from 0.9.2; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66455/ (Markdown: https://insights.sbomify.com/CVE-2025-66455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66455
- OSV: https://osv.dev/vulnerability/CVE-2025-66455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66455/
Summaries are generated and may contain mistakes; the official description above is the record.
