CVE-2025-66456 Elysia vulnerable to prototype pollution with multiple standalone schema validation
Prototype pollution in Elysia allows remote code execution when combining specific schema validation configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66456?
CVE-2025-66456 is a critical code injection vulnerability in elysiajs elysia, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.0 through 1.4.16 contain a prototype pollution vulnerability in `mergeDeep` after merging results of two standard schema validations with the same key. Due to the ordering of merging, there must be an any type that is set as a standalone guard, to allow for the `__proto__ prop` to be merged. When combined with GHSA-8vch-m3f4-q8jf this allows for a full RCE by an attacker. This issue is fixed in version 1.4.17. To workaround, remove the `__proto__ key` from body.
Weakness: CWE-1321
Which versions are affected by CVE-2025-66456?
2 open source packages ship an affected version, including elysia. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
elysia npm | From 1.4.0 | 1.4.17 |
elysia npm | From 1.4.0 | 1.4.17 |
Products include Elysiajs Elysia.
How do I fix CVE-2025-66456?
Upgrade elysia to 1.4.17 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-66456 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66456 exists.
Other vulnerabilities in elysiajs elysia
Sources
Also known as GHSA-hxj9-33pp-j2cc.