# CVE-2025-66456: Elysia vulnerable to prototype pollution with multiple standalone schema validation

> Prototype pollution in Elysia allows remote code execution when combining specific schema validation configurations.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-hxj9-33pp-j2cc

## What is CVE-2025-66456?

CVE-2025-66456 is a critical code injection vulnerability in elysiajs elysia, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.0 through 1.4.16 contain a prototype pollution vulnerability in `mergeDeep` after merging results of two standard schema validations with the same key. Due to the ordering of merging, there must be an any type that is set as a standalone guard, to allow for the `__proto__ prop` to be merged. When combined with GHSA-8vch-m3f4-q8jf this allows for a full RCE by an attacker. This issue is fixed in version 1.4.17. To workaround, remove the `__proto__ key` from body.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-66456?

2 open source packages ship an affected version, including elysia. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elysia` | npm | From 1.4.0 | 1.4.17 |
| `elysia` | npm | From 1.4.0 | 1.4.17 |

Products: Elysiajs Elysia.

## How do I fix CVE-2025-66456?

Upgrade elysia to 1.4.17 or later.

## Is CVE-2025-66456 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66456 exists.

## Other vulnerabilities in elysiajs elysia

- [CVE-2026-30837](https://insights.sbomify.com/CVE-2026-30837/): Elysia has a string URL format redos (high 7.5)
- [CVE-2025-66457](https://insights.sbomify.com/CVE-2025-66457/): Elysia affected by arbitrary code injection through cookie config (high 7.5)
- [CVE-2026-31865](https://insights.sbomify.com/CVE-2026-31865/): Elysia Cookie Value Prototype Pollution (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66456 and fix it if it is affected.

What it is: CVE-2025-66456 is a critical code injection vulnerability in elysiajs elysia, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66456 exists.

Affected packages and fixed versions:
- elysia (npm): affected from 1.4.0; fixed in 1.4.17
- elysia (npm): affected from 1.4.0; fixed in 1.4.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66456/ (Markdown: https://insights.sbomify.com/CVE-2025-66456/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66456
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66456
- OSV: https://osv.dev/vulnerability/CVE-2025-66456

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66456/
Summaries are generated and may contain mistakes; the official description above is the record.
