{"answers":{"affected":"2 open source packages ship an affected version, including elysia. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66457 exists.","fix":"Upgrade elysia to 1.4.18 or later.","what":"CVE-2025-66457 is a high-severity code injection vulnerability in elysiajs elysia, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66457 and fix it if it is affected.\n\nWhat it is: CVE-2025-66457 is a high-severity code injection vulnerability in elysiajs elysia, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66457 exists.\n\nAffected packages and fixed versions:\n- elysia (npm): affected all versions; fixed in 1.4.18\n- elysia (npm): affected all versions; fixed in 1.4.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66457/ (Markdown: https://insights.sbomify.com/CVE-2025-66457/index.md)","id":"CVE-2025-66457","markdown":"https://insights.sbomify.com/CVE-2025-66457/index.md","name":"CVE-2025-66457","record":{"aliases":["GHSA-8vch-m3f4-q8jf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Elysia TypeScript framework","requires_auth":"high_privilege","summary":"Attackers with write access to cookie config can inject arbitrary code into Elysia routes, leading to remote code execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"elysia","vendor":"elysiajs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.17 and below are subject to arbitrary code execution from cookie config. When dynamic cookies are enabled (e.g. there  an existing cookie schema), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, but when combined with GHSA-hxj9-33pp-j2cc, it allows for a full RCE chain. An attack requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie config (perhaps where it is assumed to be provisioned by the environment). This issue is fixed in version 1.4.18.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Elysia affected by arbitrary code injection through cookie config","id":"CVE-2025-66457","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"Lookyloo has multiple XSS due to unsafe use of f-strings in Markup","id":"CVE-2025-66458"},"packages":[{"ecosystem":"npm","fixed":["1.4.18"],"introduced":["0"],"last_affected":[],"package":"elysia","purl":null,"source":"GHSA-8vch-m3f4-q8jf"},{"ecosystem":"npm","fixed":["1.4.18"],"introduced":["0"],"last_affected":[],"package":"elysia","purl":"pkg:npm/elysia","source":"GHSA-8vch-m3f4-q8jf"}],"prev":{"headline":"Elysia vulnerable to prototype pollution with multiple standalone schema validation","id":"CVE-2025-66456"},"products":["elysia"],"published":"2025-12-09","related":[{"cvss_score":9.1,"headline":"Elysia vulnerable to prototype pollution with multiple standalone schema validation","id":"CVE-2025-66456","kev_date_added":null,"published":"2025-12-09"},{"cvss_score":7.5,"headline":"Elysia has a string URL format redos","id":"CVE-2026-30837","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":6.5,"headline":"Elysia Cookie Value Prototype Pollution","id":"CVE-2026-31865","kev_date_added":null,"published":"2026-03-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-12","vendors":["elysiajs"]},"summary":"Attackers with write access to cookie config can inject arbitrary code into Elysia routes, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2025-66457/"}