# CVE-2025-66457: Elysia affected by arbitrary code injection through cookie config

> Attackers with write access to cookie config can inject arbitrary code into Elysia routes, leading to remote code execution.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 12 Dec 2025
- **Also known as:** GHSA-8vch-m3f4-q8jf

## What is CVE-2025-66457?

CVE-2025-66457 is a high-severity code injection vulnerability in elysiajs elysia, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.17 and below are subject to arbitrary code execution from cookie config. When dynamic cookies are enabled (e.g. there  an existing cookie schema), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, but when combined with GHSA-hxj9-33pp-j2cc, it allows for a full RCE chain. An attack requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie config (perhaps where it is assumed to be provisioned by the environment). This issue is fixed in version 1.4.18.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-66457?

2 open source packages ship an affected version, including elysia. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elysia` | npm | All versions | 1.4.18 |
| `elysia` | npm | All versions | 1.4.18 |

Products: Elysiajs Elysia.

## How do I fix CVE-2025-66457?

Upgrade elysia to 1.4.18 or later.

## Is CVE-2025-66457 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66457 exists.

## Other vulnerabilities in elysiajs elysia

- [CVE-2025-66456](https://insights.sbomify.com/CVE-2025-66456/): Elysia vulnerable to prototype pollution with multiple standalone schema validation (critical 9.1)
- [CVE-2026-30837](https://insights.sbomify.com/CVE-2026-30837/): Elysia has a string URL format redos (high 7.5)
- [CVE-2026-31865](https://insights.sbomify.com/CVE-2026-31865/): Elysia Cookie Value Prototype Pollution (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66457 and fix it if it is affected.

What it is: CVE-2025-66457 is a high-severity code injection vulnerability in elysiajs elysia, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66457 exists.

Affected packages and fixed versions:
- elysia (npm): affected all versions; fixed in 1.4.18
- elysia (npm): affected all versions; fixed in 1.4.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66457/ (Markdown: https://insights.sbomify.com/CVE-2025-66457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66457
- OSV: https://osv.dev/vulnerability/CVE-2025-66457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66457/
Summaries are generated and may contain mistakes; the official description above is the record.
