{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-66458 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-66458 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-66458 is a medium-severity cross-site scripting vulnerability in lookyloo, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-66458 and fix it if it is affected.\n\nWhat it is: CVE-2025-66458 is a medium-severity cross-site scripting vulnerability in lookyloo, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-66458 in the wild and no public exploit code.\n\nAffected product: lookyloo. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66458/ (Markdown: https://insights.sbomify.com/CVE-2025-66458/index.md)","id":"CVE-2025-66458","markdown":"https://insights.sbomify.com/CVE-2025-66458/index.md","name":"CVE-2025-66458","record":{"aliases":["GHSA-58h2-652v-gq87"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Lookyloo web interface","requires_auth":"none","summary":"Attacker can execute arbitrary JavaScript via malicious JSON responses, affecting Lookyloo users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lookyloo","vendor":"lookyloo"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, there are multiple XSS due to unsafe use of f-strings in Markup. The issue requires a malicious 3rd party server responding with a JSON document containing JS code in a script element. This vulnerability is fixed in 1.35.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Lookyloo has multiple XSS due to unsafe use of f-strings in Markup","id":"CVE-2025-66458","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Lookyloo vulnerable to XSS due to unescaped error message passed to innerHTML","id":"CVE-2025-66459"},"packages":[],"prev":{"headline":"Elysia affected by arbitrary code injection through cookie config","id":"CVE-2025-66457"},"products":["lookyloo"],"published":"2025-12-02","related":[{"cvss_score":5.3,"headline":"Lookyloo vulnerable to XSS due to unescaped error message passed to innerHTML","id":"CVE-2025-66459","kev_date_added":null,"published":"2025-12-02"},{"cvss_score":5.3,"headline":"Lookyloo vulnerable to XSS due to lack of escaping in HTML elements passed to Datatables","id":"CVE-2025-66460","kev_date_added":null,"published":"2025-12-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-02","vendors":["Lookyloo"]},"summary":"Attacker can execute arbitrary JavaScript via malicious JSON responses, affecting Lookyloo users.","url":"https://insights.sbomify.com/CVE-2025-66458/"}