# CVE-2025-66459: Lookyloo vulnerable to XSS due to unescaped error message passed to innerHTML

> Attacker can execute arbitrary JavaScript via unescaped error messages when capturing malicious URLs in Lookyloo.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-hvmh-j2jx-48wg

## What is CVE-2025-66459?

CVE-2025-66459 is a medium-severity cross-site scripting vulnerability in lookyloo, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, a XSS vulnerability can be triggered when a user submits a list of URLs to capture, one of them contains a HTML element, and the capture fails. Then, the error field is populated with an error message that contains the bad URL they tried to capture, triggering the XSS. This vulnerability is fixed in 1.35.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-66459?

It affects 1 product.


Products: Lookyloo Lookyloo.

## How do I fix CVE-2025-66459?

No fix has been published for CVE-2025-66459 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-66459 being exploited?

There is no known exploitation of CVE-2025-66459 in the wild and no public exploit code.

## Other vulnerabilities in lookyloo

- [CVE-2025-66458](https://insights.sbomify.com/CVE-2025-66458/): Lookyloo has multiple XSS due to unsafe use of f-strings in Markup (medium 5.3)
- [CVE-2025-66460](https://insights.sbomify.com/CVE-2025-66460/): Lookyloo vulnerable to XSS due to lack of escaping in HTML elements passed to Datatables (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66459 and fix it if it is affected.

What it is: CVE-2025-66459 is a medium-severity cross-site scripting vulnerability in lookyloo, published on 2 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-66459 in the wild and no public exploit code.

Affected product: lookyloo. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66459/ (Markdown: https://insights.sbomify.com/CVE-2025-66459/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66459
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66459
- OSV: https://osv.dev/vulnerability/CVE-2025-66459

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66459/
Summaries are generated and may contain mistakes; the official description above is the record.
