CVE-2025-66468 Aimeos GrapesJS CMS extension possible stores XSS exploitable by authenticated editors

High 7.7 Published Updated

Authenticated editors can inject JavaScript for stored XSS attacks in the Aimeos GrapesJS CMS extension if Content Security Policy is disabled.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-66468?

CVE-2025-66468 is a high-severity cross-site scripting vulnerability in aimeos ai-cms-grapesjs, published on 2 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

The Aimeos GrapesJS CMS extension provides page editor for creating content pages based on extensible components. Prior to 2021.10.8, 2022.10.8, 2023.10.8, 2024.10.8, and 2025.10.8, Javascript code can be injected by malicious editors for a stored XSS attack if the standard Content Security Policy is disabled. This vulnerability is fixed in 2021.10.8, 2022.10.8, 2023.10.8, 2024.10.8, and 2025.10.8.

Weakness: CWE-79

Which versions are affected by CVE-2025-66468?

10 open source packages ship an affected version, including aimeos/ai-cms-grapesjs. It affects 1 product.

PackageAffectedFixed in
aimeos/ai-cms-grapesjs PackagistFrom 2021.04.12021.10.8
aimeos/ai-cms-grapesjs PackagistFrom 2021.04.12021.10.8
aimeos/ai-cms-grapesjs PackagistFrom 2022.04.12022.10.9
aimeos/ai-cms-grapesjs PackagistFrom 2022.04.12022.10.9
aimeos/ai-cms-grapesjs PackagistFrom 2023.04.12023.10.15
aimeos/ai-cms-grapesjs PackagistFrom 2023.04.12023.10.15
4 more packages
aimeos/ai-cms-grapesjs PackagistFrom 2024.04.12024.10.8
aimeos/ai-cms-grapesjs PackagistFrom 2024.04.12024.10.8
aimeos/ai-cms-grapesjs PackagistFrom 2025.04.12025.10.2
aimeos/ai-cms-grapesjs PackagistFrom 2025.04.12025.10.2

Products include Aimeos Grapesjs Cms.

How do I fix CVE-2025-66468?

Upgrade aimeos/ai-cms-grapesjs to a fixed version for your release line: 2021.10.8, 2022.10.9, 2023.10.15 or 2024.10.8.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-66468 being exploited?

There is no known exploitation of CVE-2025-66468 in the wild and no public exploit code.

Sources

Also known as GHSA-424m-fj2q-g7vg.

Is CVE-2025-66468 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free