# CVE-2025-66468: Aimeos GrapesJS CMS extension possible stores XSS exploitable by authenticated editors

> Authenticated editors can inject JavaScript for stored XSS attacks in the Aimeos GrapesJS CMS extension if Content Security Policy is disabled.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Dec 2025
- **Updated:** 2 Dec 2025
- **Also known as:** GHSA-424m-fj2q-g7vg

## What is CVE-2025-66468?

CVE-2025-66468 is a high-severity cross-site scripting vulnerability in aimeos ai-cms-grapesjs, published on 2 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Aimeos GrapesJS CMS extension provides page editor for creating content pages based on extensible components. Prior to 2021.10.8, 2022.10.8, 2023.10.8, 2024.10.8, and 2025.10.8, Javascript code can be injected by malicious editors for a stored XSS attack if the standard Content Security Policy is disabled. This vulnerability is fixed in 2021.10.8, 2022.10.8, 2023.10.8, 2024.10.8, and 2025.10.8.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-66468?

10 open source packages ship an affected version, including aimeos/ai-cms-grapesjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2021.04.1 | 2021.10.8 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2021.04.1 | 2021.10.8 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2022.04.1 | 2022.10.9 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2022.04.1 | 2022.10.9 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2023.04.1 | 2023.10.15 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2023.04.1 | 2023.10.15 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2024.04.1 | 2024.10.8 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2024.04.1 | 2024.10.8 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2025.04.1 | 2025.10.2 |
| `aimeos/ai-cms-grapesjs` | Packagist | From 2025.04.1 | 2025.10.2 |

Products: Aimeos Grapesjs Cms.

## How do I fix CVE-2025-66468?

Upgrade aimeos/ai-cms-grapesjs to a fixed version for your release line: 2021.10.8, 2022.10.9, 2023.10.15 or 2024.10.8.

## Is CVE-2025-66468 being exploited?

There is no known exploitation of CVE-2025-66468 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66468 and fix it if it is affected.

What it is: CVE-2025-66468 is a high-severity cross-site scripting vulnerability in aimeos ai-cms-grapesjs, published on 2 Dec 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-66468 in the wild and no public exploit code.

Affected packages and fixed versions:
- aimeos/ai-cms-grapesjs (Packagist): affected from 2021.04.1; fixed in 2021.10.8
- aimeos/ai-cms-grapesjs (Packagist): affected from 2021.04.1; fixed in 2021.10.8
- aimeos/ai-cms-grapesjs (Packagist): affected from 2022.04.1; fixed in 2022.10.9
- aimeos/ai-cms-grapesjs (Packagist): affected from 2022.04.1; fixed in 2022.10.9
- aimeos/ai-cms-grapesjs (Packagist): affected from 2023.04.1; fixed in 2023.10.15
- aimeos/ai-cms-grapesjs (Packagist): affected from 2023.04.1; fixed in 2023.10.15
- aimeos/ai-cms-grapesjs (Packagist): affected from 2024.04.1; fixed in 2024.10.8
- aimeos/ai-cms-grapesjs (Packagist): affected from 2024.04.1; fixed in 2024.10.8
- aimeos/ai-cms-grapesjs (Packagist): affected from 2025.04.1; fixed in 2025.10.2
- aimeos/ai-cms-grapesjs (Packagist): affected from 2025.04.1; fixed in 2025.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66468/ (Markdown: https://insights.sbomify.com/CVE-2025-66468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66468
- OSV: https://osv.dev/vulnerability/CVE-2025-66468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66468/
Summaries are generated and may contain mistakes; the official description above is the record.
