# CVE-2025-66470: NiceGUI Stored/Reflected XSS in ui.interactive_image via unsanitized SVG content

> Attackers can inject malicious scripts via unsanitized SVG content in NiceGUI's interactive image component, affecting multi-user applications.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-2m4f-cg75-76w2, PYSEC-2026-1696

## What is CVE-2025-66470?

CVE-2025-66470 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are subject to a XSS vulnerability through the ui.interactive_image component of NiceGUI. The component renders SVG content using Vue's v-html directive without any sanitization. This allows attackers to inject malicious HTML or JavaScript via the SVG <foreignObject> tag whenever the image component is rendered or updated. This is particularly dangerous for dashboards or multi-user applications displaying user-generated content or annotations. This issue is fixed in version 3.4.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-66470?

3 open source packages ship an affected version, including nicegui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nicegui` | PyPI | All versions | 3.4.0 |
| `nicegui` | PyPI | All versions | 3.4.0 |
| `nicegui` | PyPI | All versions | 3.4.0 |

Products: Zauberzeug Nicegui.

## How do I fix CVE-2025-66470?

Upgrade nicegui to 3.4.0 or later.

## Is CVE-2025-66470 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66470 exists.

Public exploit code:

- A fast, simple scanner for detecting CVE-2025-66470 - XSS vulnerability in NiceGUI's ui.interactive_image component. (github_poc): https://github.com/Jmehta10/CVE-2025-66470

## Other vulnerabilities in zauberzeug nicegui

- [CVE-2026-25732](https://insights.sbomify.com/CVE-2026-25732/): NiceGUI's Path Traversal via Unsanitized FileUpload.name Enables Arbitrary File Write (high 7.5)
- [CVE-2025-66645](https://insights.sbomify.com/CVE-2025-66645/): NiceGUI Path Traversal Vulnerability in app.add_media_files() Allows Arbitrary File Reading (high 7.5)
- [CVE-2026-21873](https://insights.sbomify.com/CVE-2026-21873/): Zero-click XSS in all NiceGUI apps which uses `ui.sub_pages` (high 7.2)
- [CVE-2026-33332](https://insights.sbomify.com/CVE-2026-33332/): NiceGUI's unvalidated chunk size parameter in media routes can cause memory exhaustion (medium 6.9)
- [CVE-2026-27156](https://insights.sbomify.com/CVE-2026-27156/): NiceGUI has XSS via Code Injection (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66470 and fix it if it is affected.

What it is: CVE-2025-66470 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 9 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66470 exists.

Affected packages and fixed versions:
- nicegui (PyPI): affected all versions; fixed in 3.4.0
- nicegui (PyPI): affected all versions; fixed in 3.4.0
- nicegui (PyPI): affected all versions; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66470/ (Markdown: https://insights.sbomify.com/CVE-2025-66470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66470
- OSV: https://osv.dev/vulnerability/CVE-2025-66470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66470/
Summaries are generated and may contain mistakes; the official description above is the record.
