CVE-2025-66473 XWiki's REST APIs don't enforce any limits, leading to unavailability and OOM in large wikis

High 8.7 Published Updated

Attackers can cause denial of service in XWiki by requesting unlimited items via REST APIs, leading to memory exhaustion and unavailability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-66473?

CVE-2025-66473 is a high-severity denial of service vulnerability in Xwiki Xwiki, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

XWiki is an open-source wiki software platform. Versions 16.10.10 and below, 17.0.0-rc-1 through 17.4.3 and 17.5.0-rc-1 through 17.6.0 contain a REST API which doesn't enforce any limits for the number of items that can be requested in a single request at the moment. Depending on the number of pages in the wiki and the memory configuration, this can lead to slowness and unavailability of the wiki. As an example, the /rest/wikis/xwiki/spaces resource returns all spaces on the wiki by default, which are basically all pages. This issue is fixed in versions 17.4.4 and 16.10.11.

Weakness: CWE-770

Which versions are affected by CVE-2025-66473?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rest-server. It affects 1 product.

PackageAffectedFixed in
org.xwiki.platform:xwiki-platform-rest-server MavenAll versions16.10.11
org.xwiki.platform:xwiki-platform-rest-server MavenAll versions16.10.11
org.xwiki.platform:xwiki-platform-rest-server MavenFrom 17.0.0-rc-117.4.4
org.xwiki.platform:xwiki-platform-rest-server MavenFrom 17.0.0-rc-117.4.4
org.xwiki.platform:xwiki-platform-rest-server MavenFrom 17.5.0-rc-117.7.0-rc-1
org.xwiki.platform:xwiki-platform-rest-server MavenFrom 17.5.0-rc-117.7.0-rc-1

Products include Xwiki Xwiki.

How do I fix CVE-2025-66473?

Upgrade org.xwiki.platform:xwiki-platform-rest-server to a fixed version for your release line: 16.10.11, 17.4.4 or 17.7.0-rc-1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-66473 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66473 exists.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-cc84-q3v3-mhgf.

Is CVE-2025-66473 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free