# CVE-2025-66473: XWiki's REST APIs don't enforce any limits, leading to unavailability and OOM in large wikis

> Attackers can cause denial of service in XWiki by requesting unlimited items via REST APIs, leading to memory exhaustion and unavailability.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2025
- **Updated:** 11 Dec 2025
- **Also known as:** GHSA-cc84-q3v3-mhgf

## What is CVE-2025-66473?

CVE-2025-66473 is a high-severity denial of service vulnerability in Xwiki Xwiki, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki is an open-source wiki software platform. Versions 16.10.10 and below, 17.0.0-rc-1 through 17.4.3 and 17.5.0-rc-1 through 17.6.0 contain a REST API which doesn't enforce any limits for the number of items that can be requested in a single request at the moment. Depending on the number of pages in the wiki and the memory configuration, this can lead to slowness and unavailability of the wiki. As an example, the /rest/wikis/xwiki/spaces resource returns all spaces on the wiki by default, which are basically all pages. This issue is fixed in versions 17.4.4 and 16.10.11.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-66473?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rest-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | All versions | 16.10.11 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | All versions | 16.10.11 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.0.0-rc-1 | 17.4.4 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.0.0-rc-1 | 17.4.4 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.5.0-rc-1 | 17.7.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 17.5.0-rc-1 | 17.7.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-66473?

Upgrade org.xwiki.platform:xwiki-platform-rest-server to a fixed version for your release line: 16.10.11, 17.4.4 or 17.7.0-rc-1.

## Is CVE-2025-66473 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66473 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-66473 and fix it if it is affected.

What it is: CVE-2025-66473 is a high-severity denial of service vulnerability in Xwiki Xwiki, published on 10 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66473 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected all versions; fixed in 16.10.11
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected all versions; fixed in 16.10.11
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.0.0-rc-1; fixed in 17.4.4
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.0.0-rc-1; fixed in 17.4.4
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.5.0-rc-1; fixed in 17.7.0-rc-1
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 17.5.0-rc-1; fixed in 17.7.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-66473/ (Markdown: https://insights.sbomify.com/CVE-2025-66473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-66473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-66473
- OSV: https://osv.dev/vulnerability/CVE-2025-66473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-66473/
Summaries are generated and may contain mistakes; the official description above is the record.
