CVE-2025-66474 XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection
Attackers with edit permissions can inject HTML to execute arbitrary scripts, leading to remote code execution and full wiki access.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-66474?
CVE-2025-66474 is a high-severity code injection vulnerability in xwiki-rendering, published on 10 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Versions 16.10.9 and below, 17.0.0-rc-1 through 17.4.2 and 17.5.0-rc-1 through 17.5.0 have insufficient protection against {{/html}} injection, which attackers can exploit through RCE. Any user who can edit their own profile or any other document can execute arbitrary script macros, including Groovy and Python macros, which enable remote code execution as well as unrestricted read and write access to all wiki contents. This issue is fixed in versions 16.10.10, 17.4.3 and 17.6.0-rc-1.
Which versions are affected by CVE-2025-66474?
6 open source packages ship an affected version, including org.xwiki.rendering:xwiki-rendering-xml. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.rendering:xwiki-rendering-xml Maven | All versions | 16.10.10 |
org.xwiki.rendering:xwiki-rendering-xml Maven | All versions | 16.10.10 |
org.xwiki.rendering:xwiki-rendering-xml Maven | From 17.0.0-rc-1 | 17.4.3 |
org.xwiki.rendering:xwiki-rendering-xml Maven | From 17.0.0-rc-1 | 17.4.3 |
org.xwiki.rendering:xwiki-rendering-xml Maven | From 17.5.0-rc-1 | 17.6.0-rc-1 |
org.xwiki.rendering:xwiki-rendering-xml Maven | From 17.5.0-rc-1 | 17.6.0-rc-1 |
Products include Xwiki Xwiki-Rendering.
How do I fix CVE-2025-66474?
Upgrade org.xwiki.rendering:xwiki-rendering-xml to a fixed version for your release line: 16.10.10, 17.4.3 or 17.6.0-rc-1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-66474 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66474 exists.
Other vulnerabilities in xwiki-rendering
Sources
Also known as GHSA-9xc6-c2rm-f27p.