{"answers":{"affected":"6 open source packages ship an affected version, including org.xwiki.rendering:xwiki-rendering-xml. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66474 exists.","fix":"Upgrade org.xwiki.rendering:xwiki-rendering-xml to a fixed version for your release line: 16.10.10, 17.4.3 or 17.6.0-rc-1.","what":"CVE-2025-66474 is a high-severity code injection vulnerability in xwiki-rendering, published on 10 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-66474 and fix it if it is affected.\n\nWhat it is: CVE-2025-66474 is a high-severity code injection vulnerability in xwiki-rendering, published on 10 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-66474 exists.\n\nAffected packages and fixed versions:\n- org.xwiki.rendering:xwiki-rendering-xml (Maven): affected all versions; fixed in 16.10.10\n- org.xwiki.rendering:xwiki-rendering-xml (Maven): affected all versions; fixed in 16.10.10\n- org.xwiki.rendering:xwiki-rendering-xml (Maven): affected from 17.0.0-rc-1; fixed in 17.4.3\n- org.xwiki.rendering:xwiki-rendering-xml (Maven): affected from 17.0.0-rc-1; fixed in 17.4.3\n- org.xwiki.rendering:xwiki-rendering-xml (Maven): affected from 17.5.0-rc-1; fixed in 17.6.0-rc-1\n- org.xwiki.rendering:xwiki-rendering-xml (Maven): affected from 17.5.0-rc-1; fixed in 17.6.0-rc-1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-66474/ (Markdown: https://insights.sbomify.com/CVE-2025-66474/index.md)","id":"CVE-2025-66474","markdown":"https://insights.sbomify.com/CVE-2025-66474/index.md","name":"CVE-2025-66474","record":{"aliases":["GHSA-9xc6-c2rm-f27p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"XWiki rendering system","requires_auth":"low_privilege","summary":"Attackers with edit permissions can inject HTML to execute arbitrary scripts, leading to remote code execution and full wiki access.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"xwiki-rendering","vendor":"xwiki"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Versions 16.10.9 and below, 17.0.0-rc-1 through 17.4.2 and 17.5.0-rc-1 through 17.5.0 have insufficient protection against {{/html}} injection, which attackers can exploit through RCE. Any user who can edit their own profile or any other document can execute arbitrary script macros, including Groovy and Python macros, which enable remote code execution as well as unrestricted read and write access to all wiki contents. This issue is fixed in versions 16.10.10, 17.4.3 and 17.6.0-rc-1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection","id":"CVE-2025-66474","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":6,"n_references":7,"next":{"headline":"Vim for Windows Uncontrolled Search Path Element Remote Code Execution Vulnerability","id":"CVE-2025-66476"},"packages":[{"ecosystem":"Maven","fixed":["16.10.10"],"introduced":["0"],"last_affected":[],"package":"org.xwiki.rendering:xwiki-rendering-xml","purl":null,"source":"GHSA-9xc6-c2rm-f27p"},{"ecosystem":"Maven","fixed":["16.10.10"],"introduced":["0"],"last_affected":[],"package":"org.xwiki.rendering:xwiki-rendering-xml","purl":"pkg:maven/org.xwiki.rendering/xwiki-rendering-xml","source":"GHSA-9xc6-c2rm-f27p"},{"ecosystem":"Maven","fixed":["17.4.3"],"introduced":["17.0.0-rc-1"],"last_affected":[],"package":"org.xwiki.rendering:xwiki-rendering-xml","purl":null,"source":"GHSA-9xc6-c2rm-f27p"},{"ecosystem":"Maven","fixed":["17.4.3"],"introduced":["17.0.0-rc-1"],"last_affected":[],"package":"org.xwiki.rendering:xwiki-rendering-xml","purl":"pkg:maven/org.xwiki.rendering/xwiki-rendering-xml","source":"GHSA-9xc6-c2rm-f27p"},{"ecosystem":"Maven","fixed":["17.6.0-rc-1"],"introduced":["17.5.0-rc-1"],"last_affected":[],"package":"org.xwiki.rendering:xwiki-rendering-xml","purl":null,"source":"GHSA-9xc6-c2rm-f27p"},{"ecosystem":"Maven","fixed":["17.6.0-rc-1"],"introduced":["17.5.0-rc-1"],"last_affected":[],"package":"org.xwiki.rendering:xwiki-rendering-xml","purl":"pkg:maven/org.xwiki.rendering/xwiki-rendering-xml","source":"GHSA-9xc6-c2rm-f27p"}],"prev":{"headline":"XWiki's REST APIs don't enforce any limits, leading to unavailability and OOM in large wikis","id":"CVE-2025-66473"},"products":["xwiki-rendering"],"published":"2025-12-10","related":[{"cvss_score":10,"headline":"XWiki Rendering's footnote macro vulnerable to privilege escalation via the footnote macro","id":"CVE-2023-37912","kev_date_added":null,"published":"2023-10-25"},{"cvss_score":9.1,"headline":"org.xwiki.rendering:xwiki-rendering-xml Improper Neutralization of Invalid Characters in Identifiers in Web Pages vulnerability","id":"CVE-2023-37908","kev_date_added":null,"published":"2023-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-11","vendors":["xwiki"]},"summary":"Attackers with edit permissions can inject HTML to execute arbitrary scripts, leading to remote code execution and full wiki access.","url":"https://insights.sbomify.com/CVE-2025-66474/"}